cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
memyselfni
Paper Tape
Posts: 7
Registered: ‎06-15-2016
Location: US
Views: 1,199
Message 1 of 8

Y50-70 - Cursor Goes Crazy!!

Hey guys,

 

So the issue I'm having is that very frequently, I'd be on my Y50-70 4K Touch, and the cursor goes crazy in the right lower corner! It is soooo annoying since everything spazzes out for a solid 30 seconds everytime it happens, and it happens very often. This video is an example of this annoyance. What can be the issue??

 

Mod's Edit: System model added to the front of Subject line to improve visibility / clarity.

 

Retired Support Specialist
Posts: 3,772
Registered: ‎12-24-2015
Location: IN
Views: 1,170
Message 2 of 8

Re: Cursor Goes Crazy!!

Welcome to the Forums Memy.

 

Sounds like the autocalibration on your Trackpoint has gone haywire. Does the jumping stop when you touch the TrackPad and resume immediately after you lift your fingers off it?

 

For me, I went back to the last known good configuration, and discovered that the problem was due to the program "AdAware" on my system... the new version of ad-aware was running too many different background.

 

Also, check if this persist in safe mode.

 

Update us how it goes.

 

 

 

Regards,

 

Tap that kudos button if I helped 
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! 

memyselfni
Paper Tape
Posts: 7
Registered: ‎06-15-2016
Location: US
Views: 1,150
Message 3 of 8

Re: Cursor Goes Crazy!!

Hello!

 

Thank you for the suggestions.. I completely reset the computer and reinstalled windows, and unfortunately it continues to happen.. It also happens in safe mode so I'm assuming it's a hardware problem.

 

I have disabled the touchscreen, and it hasn't done it since, so I can finally get proper work done.

 

I am just bummed out a bit, since the touchscreen was one of the main reasons I chose to buy this laptop over others.

 

I'm hoping there can be a solution!

 

Thank you.

Retired Support Specialist
Posts: 3,772
Registered: ‎12-24-2015
Location: IN
Views: 1,142
Message 4 of 8

Re: Cursor Goes Crazy!!

Sorry to hear that your issue has not yet been fixed.

 

There are chances for virus as well as driver problem. First you can scan for virus ,next check if there is two drivers installed for same function, if so uninstall both and check with either one.

 

Update us how it goes.

 

 

 

 

Regards,

 

Tap that kudos button if I helped 
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! 

memyselfni
Paper Tape
Posts: 7
Registered: ‎06-15-2016
Location: US
Views: 1,129
Message 5 of 8

Re: Cursor Goes Crazy!!

Scanned for virus using the pre-installed McAfee: all clear.

Uninstalled and repeat with AVG, Avast, and Avira: all clear.

There are also no other issues with the computer, so I'm going to assume it's clear of viruses.

 

As far as the drivers go, the problem occured during the setup of windows right after I cleaned the drive, and after all the drivers were updated. In any case, there doesn't seem to be an overlap.

Retired Support Specialist
Posts: 3,772
Registered: ‎12-24-2015
Location: IN
Views: 1,126
Message 6 of 8

Re: Cursor Goes Crazy!!

Windows 8 and later operating systems come with a built-in option to prevent accidentally moving cursor while typing. You can find this option in PC Settings (Metro Control Panel).

 

  1. Open Charms Bar by moving your mouse cursor to top-right or bottom-right corner of screen and then click on Settings option.
  2. Now click on "Change PC settings" option given at the bottom.
  3. It'll open Metro Control Panel or PC Settings page. Now go to "PC and devices -> Mouse and touchpad".
  4. Now you just need to change the value of "To help prevent the cursor from accidentally moving while you type, change the delay before clicks work" option. First change its value to "No delay (always on)". If it doesn't work for you, try to change its value to "Long delay".

Capture.JPG

 

Also, uncheck "enhance pointer precision, and click apply, that will stop the mouse from acting crazy.See below pic

 

Enhance-Pointer-Precision2.jpg

Update us how it goes.

 

 

 

 

Regards,

 

Tap that kudos button if I helped 
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! 

memyselfni
Paper Tape
Posts: 7
Registered: ‎06-15-2016
Location: US
Views: 1,113
Message 7 of 8

Re: Cursor Goes Crazy!!

It still persists... Gahh this is quite frustrating - everytime I get a suggestion my hopes go up, only to see it fail Smiley Sad

Retired Support Specialist
Posts: 3,772
Registered: ‎12-24-2015
Location: IN
Views: 1,101
Message 8 of 8

Re: Cursor Goes Crazy!!

We are sorry to hear that your issue has not yet been fixed.

 

If this is occurring during installation and in safe mode, but not when the touch screen is disabled, it points to a hardware issue. Hence i would suggest you visit the nearest Lenovo service centres for hardware assistance.

 

Update us how it goes.

 

 

 

Regards,

 

Tap that kudos button if I helped 
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! 

Top Kudoed Authors