cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
chaos03
What's DOS?
Posts: 2
Registered: ‎02-24-2015
Location: Germany
Views: 5,587
Message 1 of 6

Y50-70 USB 2.0 problem

Hi all,

 

I just received my Lenovo Y50-70 yesterday and my USB 2.0 port was working fine. Then the problem with the USB came today. I tried connecting my USB stick and my mouse (tested both on my old laptop and they work) to this port but an error keeps popping out : "USB Device not recognized". 

 

I tried updating the driver, uninstalling it on Device Manager and restarting. Yet the problem persists.

 

Does anyone have the same problem? Or does anyone know a fix for this?

 

I have Windows 7 Pro installed. 

Social Support Agent
Social Support Agent
Posts: 2,422
Registered: ‎08-10-2014
Location: IN
Views: 5,577
Message 2 of 6

Re: Y50-70 USB 2.0 problem

Hi Chaos03,

 

Welcome to Lenovo Community!

 

As per the query we understood that you are facing issue with charging issue with USB port not working in your Lenovo Y50-70 laptop

 

As you have mentioned that you have reinstall the drivers but still the same issue, please try to boot the system in the safe mode and check for the issue.

 

Check if the USB port is damaged, if not try to reinstall the operating system and check for the issue if still the same issue then it might be issue with the USB which might be replaced. Please visit the nearest service center for further details.

 

Click here to open a link where you can select the country and get the exact contact support number. I’m sure

they will be a great help.

 

Hope this helps. Do post back if issue persists!

 

Best regards,       

                                     

Ashwin.S



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Guru
Posts: 3,465
Registered: ‎04-02-2014
Location: MX
Views: 5,567
Message 3 of 6

Re: Y50-70 USB 2.0 problem

Have you connected anything else to your laptop?

 

Disconnect everything else (except charger), shutdown the laptop, start it up and test again.

 

Is this a wireless mouse or a wired one?

---------------------------------
Current System - Lenovo Y720
Y720 REVIEW - Youtube Link (Opens in New Tab)
If your experience was good today, please feel free to give KUDOS. It Ain't Over, 'til it's over.
chaos03
What's DOS?
Posts: 2
Registered: ‎02-24-2015
Location: Germany
Views: 5,564
Message 4 of 6

Re: Y50-70 USB 2.0 problem

Hi,

 

thanks for the suggested solution. I found out that one of the pins in the port was broken. Just sent it back to them today.

 

Social Support Agent
Social Support Agent
Posts: 2,422
Registered: ‎08-10-2014
Location: IN
Views: 5,543
Message 5 of 6

Re: Y50-70 USB 2.0 problem

Hi Chaos03,

 

I am glad to know that your query has been answered. Please feel free to post in Lenovo Community Forums if you have any further queries!

 

Did someone help you today? Press the star on the left to thank them with a Kudo!

 

Cheers!

 

Ashwin.S



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

ezazez77
What's DOS?
Posts: 1
Registered: ‎09-21-2016
Location: KW
Views: 2,850
Message 6 of 6

Re: Y50-70 USB 2.0 problem

Hi

 

I have had my laptop for nearly two years now and it has been an acceptional piece of technology ever since I got it. However, two days ago my USB connected mouse stopped working. When you connect it it lights up but then does not respond and eventually turns off. I thought it might be the mouse itself but was not. All other mices I tried also did not work. I tried restarting, disconnecting anything else and then restarting, as well as going back to a previous recovery point. Nothing seems to work. I also tried the Device Manager by uninstalling and updating the driver, installing the newest driver from the lenovo support webpage as well. Nothing seems to work. To Note: everything else I connect to the USB ports work fine (External HDD, Flash drives etc...) Would appreciate any help you can provide.

Cheers

We're moving

To a new platform very soon

Learn More

Check out current deals!


Shop current deals

Top Kudoed Authors