English Community

Lenovo NotebooksLenovo P, Y and Z series Notebooks Knowledge Base

Y50-70 doesn't use Nvidia GeForce on external monitor

Question

I bought my Y50-70 without a pre-installed OS and I struggled with the drivers but have not been able to get my notebook make use of the built-in Nvidia GeForce 860M.

 

I reinstalled Win 8.1 (again), followed by updating

 

- both chipset drivers

- storage drivers

- energy managment drivers

- Intel video card drivers

- Nvidia video card drivers

 

from the Lenovo download page - nothing else except one game for testing. And that worked, the game ran perfectly - until I rebooted.

 

Now it's the same situation as before. Both (Intel and Nvidia) drivers are proper according to the device manager. But the game (Planetside 2) runs with 20fps again - instead of 90fps before rebooting. I have the laptop connected to a larger external monitor.

Answer

Ensure that your laptop lid remains open when in use as the integrated Intel GPU will not kick in.

 

When the lid is closed the integrated Intel GPU is used while the lid is closed. 

Was this information helpful?

Yes No

Comments

jacanterbury On 2015-06-11, 14:07 PM

How would I disable this, ie, STOP the intel gpu kicking in when the lid is closed.

I need to use the GeForce via the HDMI output but with the lid closed. Is there a registry key or something in power management to change this setting?

brian1208 On 2015-06-15, 4:11 AM

from what I can see after a day of use the Intel GPU GPU remains the primary GPU whatever settings I make on my Z70 (I've made all the setting changes advised in the Lenovo help files on this)

 

This is the case when working using the Laptop screen without the external monitor being plugged in and with the screen open

 

Have I missed something?

 

Note - this is the case with the Laptop arriving with Win 8.1 pre-installed

jacanterbury On 2015-06-22, 13:50 PM

Serene_Lenovo  - have you made any progress with this?

 

I'm about to buy a Y50-70 but only if I can get GeForce output to the external monitor with the laptop closed.

 

mghtbgiant On 2015-06-26, 21:03 PM

Is there any insight here? I can't seem to get my brand new work y70 to use the NVidia graphics card for any external displays! What the heck is going on!? And, moreso, why can't even the crummy Intel onboard graphics push 2560 x 1600 via either HDMI or USB (through a replicator)? I've had a 30" monitor running 2560 x 1600 for 5 years. This is a brand new laptop and can't push out high res?! It's crazy to me!!

 

EDIT: I presently have the Intel display adapter disabled in the device manager. I have video on the laptop display but I can no longer get ANY external displays to work. Which means, to me, it would seem that the NVidia GPU is 100% relegated to the laptop display, ONLY.

liujeffqi On 2015-07-03, 2:06 AM

Did you try nvida control panel --> 3d setting and set it use nvida graphic only. that is what i did and using nvida gpu while plug into external monitor, there is no point using intel gpu anyway

jacanterbury On 2015-07-03, 8:32 AM

but take care to leave the lid up as I believe closing it covers some air vents so it may overheat if you're pushing the GPU.

mghtbgiant On 2015-07-06, 14:34 PM

I did set the 3D setting in the nvidial control panel to nvidia explicitly. Also, when I look at connected displays in the nvidia control panel, everything ALWAYS shows up under the Intel graphics card, period. Lid open, lid closed. Zero external monitors connected, multiple external monitors connected. I cannot seem to get the laptop to actually use the GTX-860M at all.

 

If this is some automatic "power-save" management done by Lenovo.. how about you don't?! I run this machine docked 99% of the time, plugged in. Power consumption isn't a concern. I'd like to get the most out of this laptop, please and thank you.

MrPando On 2015-09-08, 1:05 AM

I would like to add i'm new to this forum because i just recently have had problems with my Y50-70.  First problem was the issues of the hinges mounted to the display.  Which broke the display because I opened and closed the lid.

 

I thought no problem.  That was my fault. I must have opened and closed the lid to much. (come to find out this is a problem of Y50s)

 

So i removed the screen from the hinges and just connect  a seperate monitor.  Well thats just about worthless because now i can't use my gfx card.  (because i have no lid to close or open) Completely removing your screen and lid from the laptop removes the dreaded overheating problem with lid closed.  I have no lid.

 

So with all that being said, I am only slightly frustrated.  Because i know i bought a piece of **bleep** laptop specificly  for this deployment to Iraq.  I just expected it to last 6 months of laying on my bunk.  I guess, i should have only opened the lid once and never touched the garbage again. Then i wouldn't be here typing this meaningless message.

 

Respectuflly,

 

SSG 

HHC 1-137TH AVN REG

Taji, Iraq

 

 

Yeah i'm a douchebag.  Not for playing the military card.  But for buying your **bleep**.

 

 

 

NotSoFast On 2015-09-10, 1:11 AM

I have heard that the best way to ensure that the NVidia graphics card does its work is to disable the Intel HD graphics in the BIOS. Does anybody know how to get at the BIOS?

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Delete