English Community

Lenovo NotebooksLenovo P, Y and Z series Notebooks
All Forum Topics
Options

7 Posts

03-29-2015

mo

12 Signins

62 Page Views

  • Posts: 7
  • Registered: ‎03-29-2015
  • Location: mo
  • Views: 62
  • Message 1 of 2

Y50-70 touchpad button press

2017-01-01, 4:31 AM

Greetings.

 

So I recently purchased a used Y50-70 and one of the first things I noticed about it was the left and right buttons on the touch pad require either a strong tap to register, or a long press (about 1 second) before Windows recognizes the key press. The trackpad works perfectly otherwise, even tapping for a left click on the pad itself works great.

 

It doesn't feel like there is something under the button, but I do believe it is hardware related as this behavior persisted through a fresh install of Windows (ie. Windows install when I got the laptop and the reinstalled Windows). It was also present during the Windows install GUI which leads me to think it is hardware related somehow.

 

Any ideas on what the problem could be? I thought this may be a common issue with a solution somehwere on the net but I have yet to find one...

 

Thanks in advance for any help you can offer!

Reply
Options

917 Posts

07-05-2016

GB

1521 Signins

5917 Page Views

  • Posts: 917
  • Registered: ‎07-05-2016
  • Location: GB
  • Views: 5917
  • Message 2 of 2

Re: Y50-70 touchpad button press

2017-01-10, 13:27 PM

wrote:

Greetings.

 

So I recently purchased a used Y50-70 and one of the first things I noticed about it was the left and right buttons on the touch pad require either a strong tap to register, or a long press (about 1 second) before Windows recognizes the key press. The trackpad works perfectly otherwise, even tapping for a left click on the pad itself works great.

 

It doesn't feel like there is something under the button, but I do believe it is hardware related as this behavior persisted through a fresh install of Windows (ie. Windows install when I got the laptop and the reinstalled Windows). It was also present during the Windows install GUI which leads me to think it is hardware related somehow.

 

Any ideas on what the problem could be? I thought this may be a common issue with a solution somehwere on the net but I have yet to find one...

 

Thanks in advance for any help you can offer!


 

Hi Emissary3,
Not a common issue but has been seen before. Only real fix it a replacement trackpad.

 

Hope this help you and let us know how you get on


=====================================================================================
Did someone help you today? Thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!

 

This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete