cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
aurelienlt89
Not applicable
Posts: 2
Registered: ‎08-01-2016
Location: FR
Views: 9,617
Message 1 of 4

Y50 usb boot option disappeared in BIOS

Hello

 

After I recieved my Y50-70, I tried to install a linux partition for my work. I found how to activte USB boot on UEFI, but after few unsuccessful tries on different disk images, the USB boot option disappeared in the BIOS. I tried in legacy mode, it failed to boot (even if I was sure this one should not have failed), and now the USB boot option in legacy mode disappeared too.

 

I've tried every configration of the BIOS (security enabled or disabled, UEFI or legacy, USB enabled or disabled ...) and I've never seen the USB boot options anymore. I've tried both "factory" and "setup" BIOS reset, USB boot option is still absent. I've tried to flash my BIOS from Lenovo official support (http://support.lenovo.com/fr/fr/products/Laptops-and-netbooks/Lenovo-Y-Series-laptops/Y50-70-Noteboo...), but the version being the same it does not want to. I've read that advanced BIOS settings are disabled in this laptop, and there's no CD player, so I'm out of options now.

 

How can I boot on USB key and setup my computer for my work ?

 

Thank you

CyberSimian
Not applicable
Posts: 784
Registered: ‎07-10-2016
Location: GB
Views: 9,600
Message 2 of 4

Re: Y50 usb boot option disappeared in BIOS


@aurelienlt89 wrote:

I've tried every configration of the BIOS (security enabled or disabled, UEFI or legacy, USB enabled or disabled ...) and I've never seen the USB boot options anymore.


I have an Ideapad 500-15ISK, and I also have noticed that the appearance of a USB boot selection in the BIOS seems to be quite erratic.  I don't know whether this is a bug, or whether the BIOS is following a rule that I don't understand.

 

I  disabled "Secure Boot", and then selected "Legacy Boot", and "Legacy First".  With these settings saved, I found that the USB device in the list of legacy devices is present only if the USB device is already plugged in when you enter the BIOS.  Also, if I re-ordered the legacy devices in the BIOS (so that the USB device was first), saved the changes, exited the BIOS, and then re-entered the BIOS, the legacy devices had reverted to their original order.  So it seems that the device boot order cannot be changed permanently on this model.

 

What does seem to work is:

 

(1) Power off the laptop.

(2) Plug in the USB device you want to boot from (or load the CD/DVD drive with a bootable disk).

(3) Press the "Novo" button.  This will power-on the laptop and display a BIOS selection menu.

(4) Select the "Boot Menu" choice.

(5) The laptop will then display the list of devices that you can boot from.  Select the one that you want, and it should then boot.

 

Consult the "User Guide" for your model to find out where the"Novo" button is located (this manual should be available on the Lenovo website).

 

-- from CyberSimian in the UK

aurelienlt89
Not applicable
Posts: 2
Registered: ‎08-01-2016
Location: FR
Views: 9,588
Message 3 of 4

Re: Y50 usb boot option disappeared in BIOS

You're actually right, legacy USB boot appears when a USB key is present.

 

Unfortunately, as I suspected, booting on USB key does not work while on legacy. I tried my USB key on other computers, it booted. I managed to boot on UEFI USB brefore, but unfortunately I could not install because I did not make right the key at that try, and now it disappeared. Have you actually managed to boot on your USB key ?

 

Thus, UEFI USB boot option seems to be the only wait to boot on USB, unfortunately it has disappeared forever Smiley Sad

 

Any other clue ?

CyberSimian
Not applicable
Posts: 784
Registered: ‎07-10-2016
Location: GB
Views: 9,578
Message 4 of 4

Re: Y50 usb boot option disappeared in BIOS


aurelienlt89 wrote: Have you actually managed to boot on your USB key ?

Your Y50-70 may have BIOS that behaves differently from my Ideapad 500-15ISK.  I have had success doing the following:

 

(1) Booted a "System Rescue" live Linux CD loaded into the CD/DVD drive.

 

(2) Booted a Terabyte Unlimited "Bootit Bare Metal" USB stick prior to installing it as a boot manager on the hard disk.

 

(3) Booted the Windows 10 Recovery USB stick.  Using the "Novo" button to display the BIOS boot menu results in two entries for the USB stick: "USB HDD" and "EFI USB device".  I think that the former boots the memory stick as legacy, whereas the latter boots it as EFI.

 

These were all with "Secure Boot" disabled, and "Legacy Boot" and "Legacy First" enabled.  Some were using the "Novo" button to get to the BIOS boot menu, but others were simply by loading the CD or plugging in the USB stick and booting.  I had previously set the legacy boot order in the BIOS to: USB HDD, CD/DVD drive, internal HDD.  If you don't do this (or the BIOS does not remember it), you must use the "Novo" button to get the BIOS boot menu, so that you can choose a device that is not first in the boot order.

 

One point about the Windows 10 Recovery USB stick: it will default to booting in EFI mode.  To stop it doing this, either use the "Novo" button and choose "USB HDD", or plug the USB stick into a running system and rename the folder "efi" in the root directory to "efi.old".  It is the presence of this "efi" folder that causes Windows by default to boot the USB stick in EFI mode.

 

-- from CyberSimian in the UK

Check out current deals!


Shop current deals

Top Kudoed Authors