cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Faradin
Paper Tape
Posts: 1
Registered: ‎04-21-2016
Location: HU
Views: 209
Message 1 of 3

Y50 - wrong realtek driver installed after windows update on Y50

Hey everyone!

So I've been using windows 10 for a while now, but I've come across a really annoying issue recently. My laptop (y50) initiated an automated windows update a few days ago and now all sound effects are gone, and my realtek application claims that my current driver is only compatible with windows vista. I've tried to reinstall the driver from Realtek's site, but apparently the installer automatically picks vista for me. Any idea how to solve this?

 

Mod's Edit: System model added to front of Subject line to improve visibility / clarity and moved post to correct forum.

Sr Support Specialist
Posts: 9,630
Registered: ‎11-30-2015
Location: PH
Views: 170
Message 2 of 3

Re: Y50 - wrong realtek driver installed after windows update on Y50

Hi Faradin  ,

 

Welcome to the Community Forums. 

 

Windows would automatically update the drivers with its wn native drivers as it was a default on Windows. 

Every updates done are assigned with a restore date  that user may use to go back via system restore

And to prevent this from happening again as much as we hope , to disable driver update from windows and ways to uninstall such update similar to this guide .

 

Other option is to go to device manager and rihjt click on the audio driver properties to rollback driver aside from reinstalling drivers from the support site . 

 

Update us how it goes. 

 

 

Regards



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

kamalnath
Token Ring
Posts: 74
Registered: ‎04-22-2016
Location: IN
Views: 155
Message 3 of 3

Re: Y50 - wrong realtek driver installed after windows update on Y50

Its a most common issue that most of y50 users came back......Now follow these steps

 

1.Go to control panel->System->Advanced system settings->Hardware->device installation->Select No..

2.Go to control panel->device manager->Audio peripherals->Speakers(realtek HD audio)->Uninstall audio driver & tick delete driver software..

3.Download audio driver from y50 support page or get Here install it restart it then it will again install restart & done..... you got back the dolby settings Smiley Happy

Do all these steps with network disabled..... after that u can enable(important)

Dont forget to click KUDOS button(right down this sentence)if i have helped you....Ask any questions or Doubts,iam always ready to help.... Smiley Happy

Check out current deals!


Shop current deals