cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Deadp00l
Paper Tape
Posts: 3
Registered: ‎02-17-2014
Location: Canada
Views: 663
Message 1 of 3

Y510P NVIDIA 750M not working (code 34)

I have been having serious issues with the 750M (non-SLI) on this laptop. It will not work at all. I have noticed this issue on both Windows 8.1 (factory image) and Windows 7 (fresh install).

 

Device manager lists it as saying: Windows has stopped this device because it has reported problems. (Code 43). Disabling and re-enabling the device makes the screen flicker and nothing else. I have tried various driver version configurations (with a driver sweeper run each time) and NOTHING will get it to work on either OS so I am beginning to be convinced that this laptop is a POS and has had the 750M video card die.

 

Attempting to play games clearly illustrates that the intel GPU is being used instead as there is very low FPS.

DXDiag will not show the video card even if I disable the intel GPU.

GPU-Z shows the video card, but you cant see anything about frequencies or fillrates, bandwidth, sensors etc.

 

 

Deadp00l
Paper Tape
Posts: 3
Registered: ‎02-17-2014
Location: Canada
Views: 597
Message 2 of 3

Re: Y510P NVIDIA 750M not working (code 34)

Still nothing... Gonna send it back soon demanding a new one. In the meantime I must reccommend that people do not purchase the Y510p.

 

Link to picture

 

Moderator note; picture(s) totalling >50K converted to link(s) Forum Rules

happypatel
Fanfold Paper
Posts: 6
Registered: ‎05-26-2016
Location: LV
Views: 226
Message 3 of 3

Re: Y510P NVIDIA 750M not working (code 34)

My laptop only uses the Intel Integrated Graphics. I have tried almost everything to get it to work. I reinstalled all the drivers, tried old drivers, upadated from Windows 8.1 to Windows 10, uninstalled intel and NVIDIA graphics drivers and reinstalled, etc.

 

I also cannot access the NVIDIA Control Pannel. I dont see it when I right click on my desktop but I do see it in control panel, it just wont open. I also see the graphics card in device manager but no matter what I do it wont be put into use.

 

Please help,

Thanks.

 

 

Moderator comment: Merged in. Subject edited.

Check out current deals!


Shop current deals

Top Kudoed Authors