cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
OldGamer22
Paper Tape
Posts: 3
Registered: ‎06-01-2014
Location: Seattle, WA
Views: 984
Message 1 of 5

Y510P generally poor game performance

I've got a Y510p running Windows 8.1 with GT 750M SLI. I've got the latest WHQL NVidia drivers, I've installed the Lenovo patch for SLI and the control panel shows it is working. I've disabled the ExpressCache and taken a number of other steps recommended here to try to get decent performance out of this thing, but DX11 games just completely suck. I'm lucky to get more than 5-10 fps. I've got a Dell 1920x1200 monitor attached via HDMI, but regardless of whether I use that or the built in screen, have both or just one screen enabled, performance is awful. I've got 16G of RAM and task manager shows I'm using just 13% of that, so it doesn't appear to be related to memory or paging.

 

I encountered this recently with Banished, and again today with Wildstar. By setting these games to DX9, disabling antialiasing, shadows, using low resolution textures, etc., the games become almost playable but they look terrible. I can install the same games on my wife's non-gaming Dell desktop and they run just fine at full resolution and default video settings.

 

Help?

MrDanV8
Serial Port
Posts: 18
Registered: ‎01-04-2014
Location: Beirut, Lebanon
Views: 978
Message 2 of 5

Re: Y510P generally poor game performance

That's weird Smiley Frustrated  I had a similar issue when i first bought my Y510p (without SLI), turned out some of the games were being run by the integrated Intel HD graphics

 

I solved this by going in the nVidia Control Panel and specifying to use the GT750M as the default for games.

 

 

This can also be done by right-clicking on the application icon on your desktop (or wherever the game is) and selecting "run with graphics processor" and selecting the nVidia.


Hope this helps !

---------------------------------------------------------------------------------------
Y510p , single GT750M, 16 GB Ballistix Sport DDR3 1866 1.35V
Still haven't solved the SLI problem
OldGamer22
Paper Tape
Posts: 3
Registered: ‎06-01-2014
Location: Seattle, WA
Views: 959
Message 3 of 5

Re: Y510P generally poor game performance

Do all Y510p's have the Intel HD graphics? In Device Manager I only see the two NVIDIA adapters under Display Adapters. I also don't see an option for "run with graphics processor" in the right-click menu or in the shortcut properties.
MrDanV8
Serial Port
Posts: 18
Registered: ‎01-04-2014
Location: Beirut, Lebanon
Views: 954
Message 4 of 5

Re: Y510P generally poor game performance

Yes I'm pretty sure the Intel HD graphics is standard on all Y 510p's. In my device manager under Display Adapters i see the Intel HD Graphics as well as the NVIDIA GT750M.

I don't really know why the option wouldn't appear in the right-click menu :s but  you should be able to change some things through the NVIDIA Control Panel.

 

I attached some screenshots to show you what appears in my settings.

 

dvcmgr.JPG

 

desktop.jpg

 

Link to picture

 

Link to picture

 

Hope this helps !

 

 

Moderator note; picture(s) converted to link(s) About Posting Pictures In The Forums

 

---------------------------------------------------------------------------------------
Y510p , single GT750M, 16 GB Ballistix Sport DDR3 1866 1.35V
Still haven't solved the SLI problem
OldGamer22
Paper Tape
Posts: 3
Registered: ‎06-01-2014
Location: Seattle, WA
Views: 923
Message 5 of 5

Re: Y510P generally poor game performance

Thanks for the screen shots, but unfortunately Integrated Graphics doesn't show up in any of these screens for me.

Check out current deals!


Shop current deals

Top Kudoed Authors