cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
reaper_munky
Paper Tape
Posts: 1
Registered: ‎04-25-2014
Location: USA
Views: 499
Message 1 of 1

Y510p black screen, no logo

Hi,

 

My Y510p is relatively new, I got it in November 2013. Since yesterday, as I power it on, I get a black screen, and booting doesn't even get to the lenovo logo. I've tried all suggested combinations (plugged in no battery, unplugged with battery, with both), but with no success. To be precise, I tried around 40 times, and I succeeded once (unplugged, no battery, powering up by OKR), and after that it worked fine for a while.

 

Since then, I have turned the machine off, and now I have the same problem. Of course I'm trying all possibilities again (the previously successful one included) but to no avail. I cannot even get to the BIOS as nothing appears on screen.

 

Also, the power button is not broken, as I can hear the machine powering up, and I can even switch the keyboard lighting on and off with fn+space.

 

If I could manage to power it up, I would try disabling ExpressCache, but currently I'm not even getting half that far. It's really frustrating. I would really appreciate any help!

 

Thanks!

 

(I've also tried unplugging laptop and pressing power for 30 seconds, one key recovery etc., nothing I've read so far seems to work...)

Check out current deals!


Shop current deals

Top Kudoed Authors