Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
Community Spotlight

Visit the Lenovo Blogs!

Check out the ThinkPad Time Machine
Visit the Community Spotlight Blog
Windows  10

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
Reply
Token Ring
Posts: 160
Registered: ‎10-30-2009
Location: Russia
0 Kudos

Re: Y550 Virtualization Problem!!

First of all make sure that your CPU does support Intel VT. If it's so, then try to do the following:

 

- power off  your computer.

- unplug power cord.

- remove accumulator battery from your laptop.

- push the power button and hold it about 10 seconds.

- insert the battery back.

- plug the power cord.

- turn laptop on and check VT status.

- If VT is still disabled, then try to repeat VT enabling procedure.

Fanfold Paper
Posts: 3
Registered: ‎04-15-2010
Location: USA/JAPAN
0 Kudos

Re: Y550 Virtualization Problem!!

[ Edited ]

First of all Hello to this forum; I found this place a few months ago and have been following all infos. related to bios flashing in windows and linux. Most of all I have been following this particular forum, most obviously because of its success in flashing a VMX / Vt  enabled bios.



I currently have a bios {{{other than the one mentioned in this forum}} so the solved solution regarding those exact values and the Dos utility method do not (unfortunately) work for me when flashing a bios.



I can not apparently make those settings stick* Meaning I want to modify my Bios!!!! Smiley Surprised Smiley Surprised Smiley Surprised and Yes I accept the risks. >>



when running the MEL* utility update method with DUMP --> *EDIT*--> SAVE--> reboot using any methods I have tried so far both; reboot save in reset bios Default loaded settings then Alt+Ctrl+Del.



However other methods CrystalCPUID from within {OS} HAVE as of this writing It has confermed NOT Working, VT is still disabled by bios from within windows and hyper-V gives a little error to this effect stating VT is not enabled in Bios.

 

The steps I followed were:

 

Using the CrystalCPUID utility at the Default VT code::



0x0000003a my output for this code at @RDMSR is: :



EDX (63 - 32)    :: :: 0x00000000

EAX (31 - 0)       :: :: 0x00000001



so that when I go ahead and logically following the directions in this thread post:: type in 0x00000001 in EDX and 0x00000005 in EAX,

 

Im currently running windows;

 

and have a slew of kits for editing the bios if anyone wants to give me any hints?

 

well..nevertheless .. I would be better off with the ability to do this in linux startup script anyone wanna give me a clue?

thanks~

 

 

Highlighted
Fanfold Paper
Posts: 1
Registered: ‎07-05-2009
Location: Poland
0 Kudos

Re: Y550 Virtualization Problem!!

Hello,

After reading last posts in this topic I just wanted to make sure if anyone has been able to patch 15CN35WW (v2.08) BIOS and to enable VT?
I have Y550 P8600 with 15CN21WW (v1.04) BIOS and I don't know which one should I choose to install and then patch - v2.05 or v2.08 (improving battery charge process).
I also want to swap Fn - CTRL (even though I almost got used to it after 1.5 year) - but this should be easy to do since I got both BIOS versions patched by middleton (2.05 & 2.08).

 

PS: @middleton - great thanks for all those patches :-)

What's DOS?
Posts: 2
Registered: ‎02-28-2011
Location: Poland
0 Kudos

Re: Y550 Virtualization Problem!!

Hi, I have a little problem with enabling VT in my Lenovo Y550. I have BIOS v2.08, and Intel P8700 CPU with VT technology. When I finish your solution everything is OK - I have VT enabled.

 

But unfortunately, sometimes when I switch off (or hibernate etc.) my laptop VT switches off too. And after this I can't open my 64-bit virtual machine in VMware.

 

Could anyone help me?

Token Ring
Posts: 160
Registered: ‎10-30-2009
Location: Russia
0 Kudos

Re: Y550 Virtualization Problem!!

I created BIOS with VT enabled by default a very long time ago. You can download it from here.

Note: I also disabled wireless whitelist in this BIOS.

What's DOS?
Posts: 2
Registered: ‎02-28-2011
Location: Poland
0 Kudos

Re: Y550 Virtualization Problem!!

Thank you so much! Smiley Happy

Paper Tape
Posts: 1
Registered: ‎09-25-2011
Location: China
0 Kudos

Re: Y550 Virtualization Problem!!

[ Edited ]

Help~~~

 

MSR:0x0000003a

Results: EDX: 0x00000000 & EAX: 0x0000FF0F for both cores.

 

Model: Y550

CPU: T9600 @ 2.8 GHz (ES,QAER)

BIOS: 15CN34WW(V2.07)

M/B: KIWB1

Blue Screen Again
Posts: 5
Registered: ‎01-26-2013
Location: New York,
0 Kudos

Re: Y550 Virtualization Problem!!

Sorry to bring this old thread but I have the Y580 and I need to have VT enabled, middleton do you have any suggestion for me?  This is messed up that we have to go through all this hassle to turn on a simple setting which is already available.

Paper Tape
Posts: 1
Registered: ‎03-14-2014
Location: Poland
0 Kudos

Re: Y550 Virtualization Problem!!

Hello. I have Lenovo y550 with Bios v2.08. I have a problem with virtualization, my cpu Intel T9600 support virtualization but I can't enable it. In CrystalCpuId I have for MSR Number 0x0000003a values EDX 0x00000000 and EAX 0x00000009 on both core. I tried solve this problem according to instruction on page 4 but virtualization is still disabled. Someone have any ideas? Is this modified bios safe?