cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mohgaza
Paper Tape
Posts: 5
Registered: ‎07-10-2013
Location: Gaza
Views: 2,219
Message 1 of 7

Y550 bios update failure - DEAD

Hello, hope all are well

I've ideapad Y550 (4186), it was working very well on windows 7-64bit.

Yesterday, I've tried to update the BIOS, downloaded (15CN35WW(V2.08_x64) from the Y550 drivers' page, doubled click the file, the application started.

There was some charge in the battery, and the charger is connected.

On the bios application, I agreed to start update the bios, after a wile, the laptop hanged and stopped response.

After many minutes, I plugged-out the charger and the battery.

 

Tried to turn it on, no thing happen

No CPU-fan sound, no lights, nothing to tell me the lap is live Smiley Sad.

 

What can I do ??

 

Can any one back-up the bios file ( .ROM or .BIN) from his lap to try to flash it on the bios-IC ?

 

Or, how can I solve this issue ?

 

 

Any help is highly appreciated.

BRGRDS

Social Support Agent
Social Support Agent
Posts: 5,824
Registered: ‎02-11-2012
Location: PH
Views: 2,185
Message 2 of 7

Re: Y550 bios update failure - DEAD

hi mohgaza,

 

Welcome to the Forums.

 

Can you try to:

1. Remove the AC adapter and battery

2. Press and hold the power button for 30secs (power drain)

3. Re-insert the AC adapter and turn the computer ON (if you see a sign of life, read on)

4. Upon checking, the Y550 uses a Phoenix BIOS, check this thread on how to recovery the BIOS from a bad flash:

 

Bios Recovery For ideapad laptops

 

If the unit is dead, the motherboard might be shot and needs replacement.

 

 

Hope this helps



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Guru
Posts: 1,396
Registered: ‎06-08-2013
Location: BE
Views: 2,173
Message 3 of 7

Re: Y550 bios update failure - DEAD

neokenchi, can't we just replace the BIOS chip like in desktop motherboards? I believe this was possible for the Y500.

Just a suggestion on cost savings for Lenovo Smiley Happy


Warm regards,
Jonas Hendrickx

Lenovo Insider - Windows Insider MVP

Personal website: ThinkScopes

mohgaza
Paper Tape
Posts: 5
Registered: ‎07-10-2013
Location: Gaza
Views: 2,144
Message 4 of 7

Re: Y550 bios update failure - DEAD

Hello all, thanks for help.
I went to a friend, who helped in disassembling the lap, disconnect the BIOS-IC chip, wrote on it with WinPhlash tool, and reconnected it.
Now the lap works well.

BRGRDS
ishaan
Bit Torrent
Posts: 3,304
Registered: ‎06-27-2012
Location: India
Views: 2,128
Message 5 of 7

Re: Y550 bios update failure - DEAD

Yes jonas_hendrickx, it is possible. THough lenovo does not manufactures the bios chips and hence you will have to get it replaced/reflashed by local repair shops.
Regards
Ishaan Ideapad Y560(i3 330m), Hp Elitebook 8460p!(i5-2520M) Hp Pavilion n208tx(i5-4200u)
If you think a post helped you, then you can give Kudos to the post by pressing the Star on the left of the post. If you think a post solved your problem, then mark it as a solution so that others having the same problem can refer to it.
mohgaza
Paper Tape
Posts: 5
Registered: ‎07-10-2013
Location: Gaza
Views: 2,110
Message 6 of 7

Re: Y550 bios update failure - DEAD

Hello,
After flashing the BISO-Chip (IC) manually, the camera stopped working,
When i try to enable it through Fn+Esc, a message appears stating that ( no camera device found ) , or something like this.
Power management works well with audio, wireless .. etc .

I noticed that , in bios information, some lines are defined as : INVALID, or ( FFFFFFFFFFFFF ) , like: Model number, .

tried to flash the original BIOS file again ( under windows7 64bit), and the same problem appears.

I've made sure that every thing is connected and assembled well after flashing the bios-chip.

I need help, and thanks in advance.

BRGRDS
mohgaza
Paper Tape
Posts: 5
Registered: ‎07-10-2013
Location: Gaza
Views: 2,080
Message 7 of 7

Re: Y550 bios update failure - DEAD

BIOS Information:

 

Product Name: INVALID

BIOS Version:  15CN35WW (V2.08)

EC Version:      15EC39WW (V2.06)

Lenovo S/N:      INVALID

Board Number:  [Blank/Empty]

UUID Number:  FFFFFFFFF.....FFF  [37 Fs}

 

CPU Type: Intel (R) Core (TM)2 Duo CPU T6500

..

..

..

 

The other information are ordinary.

 

The current problems are: Camera don't work, i've tried every solution suggested in previous threads, and the touch volum buttons also dont work.

 

please help, and thanks in advance.

 

BRGRDS

Check out current deals!


Shop current deals

Top Kudoed Authors