English Community

Lenovo NotebooksLenovo P, Y and Z series Notebooks Knowledge Base

Y550 wireless button turned on but no sign of wireless signal

Question

I received this used laptop Y550 a few days ago. When I got it, the wifi worked well. One day, it stopped working therefore I re-installed Window 7 (Lenovo recovery CD).

 

Whenever I switched on the physical wireless button, it just doesn't do anything. No wifi signal at all. Here's what I tried so far:

 

1) Updated the driver and BIOS (Intel Wifi link 5100 AGN)

2) When setting up my Network and Sharing center, and whenever I tried trouble shooting, it says "Turn on wireless capability"

 

Should I change the wireless card?

Answer

In addtion to the physical switch, make sure you activate wireless card by pressing Fn + F5 on keyboard.

 

When you press Fn + F5, Lenovo Wireless Device Settings windows will show up. Make sure you select "on" for wireless. Image below shows the wifi card is already turned on.

 

fn+f5.jpg

 

Note: Check if your Fn keys work, otherwise re-install Lenovo Energy Management both software/utilities and drivers. There is a Hotkey driver in Lenovo Energy Management package. The hotkey is to enable the Fn keys.

Was this information helpful?

Yes No

Comments

Menardrs On 2013-01-04, 10:46 AM

I have the Y560s and when I hit FN + F5 the dbx comes up but there are icons suchas are shown in your image. Device | Current Status | Status Settings menus are present but no buttons to select. In the middle if the dbx it reads "First switch on the wireless device" . Again the icon are not present in the dbx to select. Please help!

 

Thanks.

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop