Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
What's DOS?
Posts: 2
Registered: ‎03-19-2012
Location: So. Indiana
0 Kudos
Accepted Solution

Y550p does not recognize battery

Hello All, so today my y550p decided not recognize the battery. it will boot and run with AC with or without battery but not with the battery alone. the indicator light on the outside of the pc does not light up unless with AC. I have tried flashing the BIOS, taking the battery out, and reintstalling the Microsoft ACPI controller.  Any ideas? Any help will be greatly appreciated!

Community Moderator
Posts: 1,181
Registered: ‎08-28-2011
Location: Thailand
0 Kudos

Re: Y550p does not recognize battery

Hi Seth,


after about 2 years maybe you need a new battery...



What's DOS?
Posts: 2
Registered: ‎03-19-2012
Location: So. Indiana
0 Kudos

Re: Y550p does not recognize battery

 i dont know if it would be the battery though.. it never gave any warning signs of being bad... i could still get 90 mins of power out of it.. i heard it could be the mother board.. any thoughts?

Posts: 134
Registered: ‎12-18-2011
Location: Athens

Re: Y550p does not recognize battery

Doubt it's the motherboard, buuuut a faulty battery on the other hand, could eventually cause other issues.


everybody uses and preserves their battery differently, but i agree that two years is a fine lifetime for it.


Nevertheless, check your energy power management settings, but before that, give it an update!


Heres a link to your drivers:



Good luck!

Smiley Happy

Posts: 2,223
Topics: 83
Kudos: 291
Solutions: 142
Registered: ‎05-01-2008
Location: Malaysia (GMT 0800)
0 Kudos

Re: Y550p does not recognize battery

[ Edited ]


Other forum users comments make sense. Anyhow, you may want to try doing a Battery Gauge Reset. Check out the Method B from this article on how to do the reset.

Z570 - Battery plugged in but not charging status message


Hope this helps.


WW Social Media
T61, T410, x240, Z500, Flex 14

Important Note: If you need help, post your question in the forum, and include your system type, model number and OS. Do not post your serial number.

Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!

Follow @LenovoForums on Twitter!
How to send a private message? --> Check out this article.

English English Community   Deutsche Deutsche Community   Español Comunidad en Español   ru.gif Русскоязычное Сообщество