Showing results for 
Search instead for 
Do you mean 
Reply
What's DOS?
Posts: 2
Registered: ‎03-19-2012
Location: So. Indiana
Message 1 of 5 (522 Views)

Y550p does not recognize battery

Hello All, so today my y550p decided not recognize the battery. it will boot and run with AC with or without battery but not with the battery alone. the indicator light on the outside of the pc does not light up unless with AC. I have tried flashing the BIOS, taking the battery out, and reintstalling the Microsoft ACPI controller.  Any ideas? Any help will be greatly appreciated!

Community Moderator
Posts: 1,181
Registered: ‎08-28-2011
Location: Thailand
Message 2 of 5 (519 Views)

Re: Y550p does not recognize battery

Hi Seth,

 

after about 2 years maybe you need a new battery...

http://shop.lenovo.com/SEUILibrary/controller/e/web/LenovoPortal/en_US/catalog.workflow:item.detail?...

 

Zehn

What's DOS?
Posts: 2
Registered: ‎03-19-2012
Location: So. Indiana
Message 3 of 5 (506 Views)

Re: Y550p does not recognize battery

 i dont know if it would be the battery though.. it never gave any warning signs of being bad... i could still get 90 mins of power out of it.. i heard it could be the mother board.. any thoughts?

802.11n
Posts: 134
Registered: ‎12-18-2011
Location: Athens
Message 4 of 5 (503 Views)

Re: Y550p does not recognize battery

Doubt it's the motherboard, buuuut a faulty battery on the other hand, could eventually cause other issues.

 

everybody uses and preserves their battery differently, but i agree that two years is a fine lifetime for it.

 

Nevertheless, check your energy power management settings, but before that, give it an update!

 

Heres a link to your drivers:

 

http://consumersupport.lenovo.com/gr/en/DriversDownLoads/APR_Driver_List.aspx?CategoryID=818067&OS=0

 

 

Good luck!

Smiley Happy

Posts: 2,226
Topics: 83
Kudos: 293
Solutions: 142
Registered: ‎05-01-2008
Location: MY
Message 5 of 5 (487 Views)

Re: Y550p does not recognize battery

[ Edited ]

seth959ci,

Other forum users comments make sense. Anyhow, you may want to try doing a Battery Gauge Reset. Check out the Method B from this article on how to do the reset.

Z570 - Battery plugged in but not charging status message

 

Hope this helps.


Cheers,
Cleo


T410, x240

Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!

How to send a private message? --> Check out this article.


English Community   Deutsche Community   Comunidad en Español   Русскоязычное Сообщество
top kudoed authors