cancel
Showing results for 
Search instead for 
Did you mean: 
Views: 15,250

Question

I have a Y-560 that I bought about three months ago and am having trouble getting the wifi to work in N mode.

 

I just got a new Wireless-N capable router, and when I set it up to only transmit in N-mode, my wireless no longer works. In mixed mode (B/G/N) or even N/G mixed, it works. My roommate's Macbook works when it transmits only in Wireless-N, so I can therefore conclude the problem is on my end!

 

When I go to the device manager and click on the WIFI Link 1000 BGN, I see properties like 802.11n Channel Width for Band 2.4 and 802.11n Mode. I can switch n Mode to "Enabled" but I see at the bottom a property called Wireless Mode and the only options are: B, G, and B and G. No N!

 

How do I enable Wireless-N on my laptop? 

Answer

 

The trouble may still reside with the router settings.  Wireless N can be a more demanding mode.

 

For example, with a Linksys WRT160N, it was found that enabling QoS was required.

Here's some insight to get that full Wireless N 300mbit speed:

 

http://www.smallnetbuilder.com/wireless/wireless-basics/30664-5-ways-to-fix-slow-80211n-speed

 

To summarize:

 

1) Change security to WPA2/AES

2) Force the band to be 20MHz only

 

Combined with the QoS feature, you should be getting 65mbit or 130mbit all the time. 

 

WPA2 Personal seems to be the "secret sauce" to getting some devices to see N only routers.

 

Note that in order to test this properly you must change security to WPA2 Personal on the router first, and then on the devices that connect to it.  

Was this information helpful?

Comments
deraeler

I have the exact same issue with my y570, using a cisco/linksys E3000 router.   The laptop won't even see the Wireless-n connection.   I've followed all the steps listed here - WMM, QOS, WPA2-AES are all enabled.  It just onw

t see it.  Would really appreciate hearing what others have learned with this.

 

Conections using Wireless G work fine, slow but fine.

mrwkdwizard

Have been to that article. Can't find a QoS setting on this router.