Showing results for 
Search instead for 
Do you mean 
Punch Card
Posts: 30
Registered: ‎04-19-2012
Location: usa
Message 31 of 36 (3,102 Views)

usb 3.0 ports not working

Hello, I bought my y570 in february, and regardless of the endless problems posted here on the forums, mine has been running fine till now. I have a Seagate 1tb usb 3.0 hard drive, which i have used on and offj for the past month. Today i turned on my laptop and the usb 3 ports( the ones on the right hand side, no longer work). If i plug the hard drive into it it spins up and the light comes on, but windows does not recognize, and it doesn't even beep when plugged in like the normal usb plugin sound. I've tried mice, camera etc. and nothing works on the these two usb 3.0 ports anmore. the 2 ports on the left side still work, even the combo esata/usb one still works. I've installed the renesas usb controller drivers multiple times, and when i run the utility, it says "no usb 3.0 host controller found"


usb 3.0


I've done the one key restore, and that didnt' work either. This snapshot is from after doing a one key restore session with my rescue disks. this is random as all heck and very annoying.. if anybody can help it would be great, also if more info is needed just lemme know!! Thank you.

Community Moderator
Posts: 13,484
Registered: ‎12-07-2009
Location: CZ
Message 32 of 36 (2,942 Views)

Re: usb 3.0 ports not working

hi sp0rk1859,

i believe your computer doesn't support usb 3.0.
Paper Tape
Posts: 1
Registered: ‎09-13-2012
Location: Hungary
Message 33 of 36 (2,414 Views)

Re: usb 3.0 ports not working

Hi there! I have a similar problem as Sporky had, only difference is I have 3 USB slots on my lenovo y570 bought a year ago, and every usb slot works on usb 2.0 speed. The renesans usb 3.0 latest driver says no usb 3.0 host controller found, and I cannot find either the USB 3.0 host controller or hub on the list!
usb 3.0


I guess my computer doesn't support usb 3.0 - but it should support, because when I bought it, in the description, there was usb 3.0 support! 
What can I do in this case, to whom should I turn to?

Fanfold Paper
Posts: 2
Registered: ‎09-27-2012
Location: Bulgaria
Message 34 of 36 (2,359 Views)

Y570 USB 3.0 problem



I have Lenovo Y570 with Win 7 Ulitimate, when i plug-in my new USB 3.0 HDD on right usb slots, i saw that the transfer speed is about 20-22 Mbps, should be more. /about  40-50 Mbps/

When I look in device manager, in usb serial bus controllers, i wasn't see the Renesas drivers for USB 3.0.

Before that i was installed  the Renesas drivers without error. 

And when i start the USB 3.0 Host Controller Utility - message appears "USB 3.0 Host Controller not found".

Can anybody tell me what is the problem?

Thank you.


Fanfold Paper
Posts: 2
Registered: ‎09-27-2012
Location: Bulgaria
Message 35 of 36 (2,334 Views)

Re: Y570 USB 3.0 problem

Can anybody help me???
Paper Tape
Posts: 1
Registered: ‎10-17-2012
Location: Germany
Message 36 of 36 (2,268 Views)

IdeaPad N581 USB 3.0 disconnects

[ Edited ]

Have the same problem with randon disconnetions with my Lenovo IdeaPad N581.



I tested 3 different USB 3.0 cases for 2.5" HDD drives and one seems to work better than the others.


RaidSonic IB-273StU3

seems to work better.


RaidSonic IB-223StU3+Wh and

RaidSonic IB-230StU3-G

plug off very often.


As those drives do not have a dedicated power supply,

maybe the problem is due to power consumption of the drive.


Has anyone tried to use a USB 3.0 Y-plug to supply more current to the drive?

Top kudoed Authors