Showing results for 
Search instead for 
Did you mean: 
Views: 26,779


The touchpad is slow to respond after using the keyboard. There is a lag time before the mouse will respond to the TouchPad's input. When testing using an external mouse, the mouse input works fine. 


Ensure you have the latest Synaptics TouchPad driver for your machine. Check for the latest version here


If the support's site version is newer than what you have in the system, do uninstall previous version first, reboot then only install the latest one which you have downloaded. Test the TouchPad and see if it working properly, if problem still persist, follow the step provided below to change the settings.


  1. Click Start
  2. Click Control Panel
  3. Click Mouse
  4. Select Device Settings tab
  5. Click "Settings"

device settings.png


6.  Expand the Pointing tab, and find Palm Check:




7.  Click the slider and slide the bar all the way to the left to reduce the sensitivity.




8.  Press close to save the settings.

Was this information helpful?


Thanks! I had this same problem on my Lenovo Y700, and this solution worked. I was about to send it in for a replacement. I can't beleive the Lenovo reps are unaware of this issue. I had called twice, and they updated the drivers, but the problem persisted. I'm glad it was such an easy fix.