cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
klin
Paper Tape
Posts: 2
Registered: ‎03-11-2013
Location: United States
Views: 1,969
Message 1 of 3

Y570 problems with Nvidia Geforce GT 555M graphics card

I have a Lenovo Y570 laptop, running Windows 8 64 bit. It's about a year old. I have both Intel HD and Nvidia Geforce 555M graphics cards. I installed Windows 8 on it myself several months ago; it originally came with WIndows 7 64 bit. I updated all the drivers at that time.

 

Recently - and I'm not sure how recently - the Nvidia card has been coming up with Code 43. It's disabled in the Device Manager because of this, and when I try to bring up the Nvidia control panel, it gives me some error that I can't reproduce now since I completely wiped Nvidia from my computer in an attempt to reinstall it. I uninstalled the driver in the Device Manager and then scanned for hardware changes to reinstall it. It seemed to work for a few minutes, then came up with Code 43 again.

 

I rebooted my computer after wiping all the Nvidia files. (There also didn't appear to be any Nvidia Chipset files. I don't know what that means, but it seems significant since there's an Intel chipset.) Then I grabbed the 314.07 Geforce 555M drivers from the Geforce website after not finding them on the Lenovo website, and I ran the .exe file. I didn't change the extraction path. I selected custom installation so I could run a clean installation. It appeared to install normally for several minutes. It said it was uninstalling a previous version, and then prompted a reboot. (When I tried installing it previously, before I wiped all the files, it didn't try to uninstall anything or reboot.)

 

INSTALLATION SUCCESSFUL? THIS A TURN OF EVENTS. Just kidding. I click on the Nvidia Settings icon on my taskbar, and it gives me the error message:

 

"Nvidia Display settings are not available. You are not currently using a display attached to an Nvidia GPU." The Nvidia graphics card shows up in the Device Manager. No Code 43 apparent.

 

The silver switch to change graphics cards doesn't seem to respond. The light doesn't turn on when I flick it. I tried holding it for several seconds, but no luck.

 

[b]TL;DR my Nvidia Geforce GT 555M kept coming up with Code 43 in the Device Manager. I uninstalled all the files, then reinstalled 314.07. No more Code 43, but the Nvidia Settings control panel keeps giving me an error message. I also can't use the silver switch on the front of the laptop to switch from Intel to Nvidia. The light indicating it's switched does not turn on.[/b]

Sfairat
802.11n
Posts: 145
Registered: ‎08-04-2011
Location: Odessa, Ukraine
Views: 1,946
Message 2 of 3

Re: Y570 problems with Nvidia Geforce GT 555M graphics card

I once had some problems with updating nvidia drivers; try to completely uninstall gt555m drivers and reinstall them, I think it would help.
klin
Paper Tape
Posts: 2
Registered: ‎03-11-2013
Location: United States
Views: 1,943
Message 3 of 3

Re: Y570 problems with Nvidia Geforce GT 555M graphics card

Thanks for the reply, but I've done that twice now. Still won't work.

Check out current deals!


Shop current deals

Top Kudoed Authors