Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Lenovo NotebooksLenovo P, Y and Z series Notebooks
All Forum Topics
Options

12 Posts

07-10-2015

Germany

12 Signins

185 Page Views

  • Posts: 12
  • Registered: ‎07-10-2015
  • Location: Germany
  • Views: 185
  • Message 1 of 3

Y580 screen stays black for a long time but then boots normally

2015-07-10, 7:16 AM

Hello everyone!

I have a Y580 (bought it 25 months ago.. yay...) and since two or three days, I observe a strange problem:

I switch the laptop on (no matter if battery or cable)

but the screen stays black, whereas the other parts are running (but it does not boot the OS - otherwise I would have

noticed an Error on Windows boot up, I guess).

I also checked another monitor via cable, uninstalled hdd and ram

but the problem stays the same.

Misteriously, if I leave the laptop on, it starts to boot regularly and I can work with it in a normal manner.

So finally I assume that the graphic chip is about to die?!

Any suggestions or helping comments?

Best Regards,

Daniel

Reply
Options

3508 Posts

04-02-2014

Mexico

2522 Signins

39849 Page Views

  • Posts: 3508
  • Registered: ‎04-02-2014
  • Location: Mexico
  • Views: 39849
  • Message 2 of 3

Re: Y580 screen stays black for a long time but then boots normally

2015-07-10, 14:25 PM

Do you dual boot?

Do you have SSD?

Whats your system confirguration?

---------------------------------
Current System - Lenovo Y720
Y720 REVIEW - Youtube Link (Opens in New Tab)
If your experience was good today, please feel free to give KUDOS. It Ain't Over, 'til it's over.
Reply
Options

12 Posts

07-10-2015

Germany

12 Signins

185 Page Views

  • Posts: 12
  • Registered: ‎07-10-2015
  • Location: Germany
  • Views: 185
  • Message 3 of 3

Re: Y580 screen stays black for a long time but then boots normally

2015-07-29, 14:39 PM

Hi sorry for the late reply.

I had dual boot, but now only have Windows installed.

I have a 1TB HDD installed (no ssd or msata), i7 cpu, 8GB RAM and an additional GTX 660M graphics chip.

 

By now I think it also has something to do with the temperature, since

I can boot almost normally when the laptop is cold, but having problems when he ran

several hours.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms