Showing results for 
Search instead for 
Did you mean: 
Blue Screen Again
Posts: 15
Registered: ‎02-02-2013
Location: Россия
Views: 501
Message 1 of 3

Y580 touchpad not working

Hello all!

My touchpad is not working (okay, it works 5 min, than it doesn't for an hour, than again 5 min etc), looks like a driver glitch, I'll try to explain. - here, as you can see(2 row, last one) synaptics app shows that i press in the middle of the touchpad, but of cource, i'm not doing that.

Than i opened MoodPad from synaptics, and tried to move cursor with the help of UNWORKING touchpad. The results are okay - (, touchpad is seemed to be working, but still no reaction to the cursor or buttons.

I tried to reinstall drivers, of cource, everything is the same.

Any suggestions?

Thanks for you help in advance!

Retired Support Specialist
Posts: 1,226
Registered: ‎11-18-2012
Location: Egypt
Views: 464
Message 2 of 3

Re: Y580 touchpad not working

Dear aquatko


Welcome in lenovo forums


Please follow the below steps :-


1- Shut down the machine and connect the charger

2- hold the power button for 15 Sec

3- power on the machine 


- Also please use one of the below link to download and install the latest update of the touchpad driver 


Win 7 :


Win 8 :


Please let me know if the issue still exist 




Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

Blue Screen Again
Posts: 15
Registered: ‎02-02-2013
Location: Россия
Views: 444
Message 3 of 3

Re: Y580 touchpad not working

Thank you for reply, unfortunately it didn't help.
After installing drivers from Lenovo site everything remained the same, but after installing from Synaptics, cursor began to jump directly up and down in that short period of time when touchpad worked. (not because of battery, i know this issue, i have it too).
The other time touchpad simply doesn't work as usual.

Check out current deals!

Shop current deals