cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
astooonaut
What's DOS?
Posts: 1
Registered: ‎02-19-2017
Location: CA
Views: 205
Message 1 of 2

Y580, windows 10, warranty and a faulty program/chipset just a mix of stuff that made a mess

Okay. where do i start. I've read a fair bit of stuff about this issue of mine and it seems like a fairly common problem when it comes to the Y series of notebooks (and to think that it was, at one point, the premium line) anyway. sooo. Basically, from what i garnered from reading stuff here and in other forums is that the Lenovo Energy Management tool, which is programmed to help your battery life stay longer, could potentially bypass a safely mechanism in the motherboard causing it to fry and not charge properly thereafter. Very ironic eh? so... here is what happened. I have had this laptop for over 3 years now and i absolutely love it. it runs most my stuff, i could play a fair amount of games here, i could watch in HD, It basically covers all that i require of any one computer. Up until a few months or so ago, i found that my battery does not want to charge past 69 percent which was mighty off but i ignored it as it is a fairly bulky laptop so the need to transport it isn't too great. one day though, out of curiosity, i opened the energy management tool (3 years and this is my very first time actually doing this, cause, like i said, i was content with what my computer does and found no need to tinker with it) and explored the app a bit (and not just choose energy setting or something; or fan cleaning). Here, i got to check the battery status (which was 'good'by the way) but still, it stops at 69. so i clicked on a few more buttons and i eventually found the charge cycle thing which describes the process as a full charge and a full discharge. In my mind. cool, maybe this is what my computer needs as i remember my dad telling me batteries need to discharge at one point to keep them in check, so... I clicked on it and let it do its thing overnight (also, it charged past 69! woooo! there might be hope). next day, i tried turning it on (as i assume the full discharge was underway or has been done. and it does not want to. at all. i was perplexed. this one thing never happened. (the plug was still on) and the lights were off. i took to my phone and, in a slight panic, started searching for ways to turn it back. I eventually found a few articles pointing to this problem that stems from the program + motherboard incompatibility. That's stupid, i thought why would the manufacturer not know of this before putting on the program to supposedly help it. anyway. so i called up lenovo and asked what could be the case, and they did confirm that it could be a motherboard problem to not detect a perfectly fine battery. i tried pointing out the error here that it is Lenovo who is at fault that this one program that i never tried exploring for 3 years caused this. they said they are sorry but said i cannot do much about it as it is out of warranty. Seriously? no other explanation? i mean, i should not be at fault here as this computer has been perfectly fine until i used a STOCK program in it after 3 years only to discover that the program that i have been ignoring all this time could do this. the one on the phone cannot understand what i am saying and i asked her to forward me to a tech specialist but she said she is unable to sooo. maybe posting on here where other reps of Lenovo can read this. What can i do with my computer now? i've tried various 'solutions'both temp and supposed proven ones, but all of them just allow me to do the bare minimum, which is move my laptop from one end of the room to another (there is a ritual involved in making it turn on and charge properly). i would be happy to recieve any feedback from you guys. Thanks A PS: I find it unfair that this should be a warranty thing as this was caused by a software in the computer itself that is installed by the manufacturer. it is just one i chose not to run or tweak with cause i did not find a reason to. If it were the motherboard just failing or the battery just dying on its own then i understand that it is out of warranty but if it is caused by a program that the manufacturer themselves made (thereby forcing a fault to happen) it should be covered regardless. also, there was no waiver on the full cycle thing that couldve warned me that it could cause problems if it fails,
Lenovo Technology Partner
Posts: 570
Registered: ‎07-07-2014
Location: PH
Views: 109
Message 2 of 2

Re: Y580, windows 10, warranty and a faulty program/chipset just a mix of stuff that made a mess

Hi  astooonaut, 

Sorry to hear that you have been having issues with the batter of the laptop. I would just like to ask, who did the upgrade to windows 10? If not mistaken, when the system was about to do the windows 10 upgrade, there would have been warning about programs/apps not compatible with windows 10. One of those app would have been the Lenovo Energy Management and you would have been advised to remove the app from the system. The model of your system is also not support for Windows 10.

Now I'm not really sure what happened to the system but it is surprising that the battery lasted for 3 years. It is common that after 2 years, you would have to replace the battery. If the system is still powering on please uninstall Lenovo Energy Management, and install Lenovo Settings. Check if the battery status is still good or not, and replace the battery if needed. The system might have overheated during the process so I would also recommend that you check if the fans are still running properly. 

Here are the documentation/guide about the Windows 10 upgrade :  

https://support.lenovo.com/us/en/solutions/HT103535

https://pcsupport.lenovo.com/us/en/solutions/ht103611

 

Hope this helps. 

Cheers,

Did someone help you today? Press the star on the left to thank them with a Kudos!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"

Check out current deals!


Shop current deals

Top Kudoed Authors