English Community

Lenovo NotebooksLenovo P, Y and Z series Notebooks
All Forum Topics

1 Posts



3 Signins

45 Page Views

  • Posts: 1
  • Registered: ‎05-02-2017
  • Location: SI
  • Views: 45
  • Message 1 of 3

Y70-70 Touch Laptop screen flicker

2017-05-02, 19:03 PM



I'm new to this forum.

Recently i got a lenovo Y700 laptop with Win 10 from the company where i work. the model itself is a bit older and has older components.

The issue i have is that occasionally the screen flickers when i'm using it. it's extremely irregular and unpredictable. moving the screen does not provoke it, it just happens on it's own. it NEVER happens when i'm running a game with the NVidia graphics card, from what i can tell it happens only when i'm not really doing anything with the computer. like when i'm on the internet or somewindows programs. Sometimes it goes black for a fraction of a second and sometimes it turns a weird purplish color for a fraction of a second. i've tried to get it on camera but haven't suceeded yet.

i've tried updating all my drivers and it hasn't had and effect.

i have Intel HD graphics 4600 and NVidia GeForce GTX 860M


everything else is running perfectly

Y70-70 Touch Laptop (Lenovo)

Serial Number *******
Machine Type Model 80DU00NLMT
Mod's Edit: Serial number removed from public view to protect owner from its unwanted use.

180 Posts



138 Signins

2083 Page Views

  • Posts: 180
  • Registered: ‎11-28-2016
  • Location: GB
  • Views: 2083
  • Message 2 of 3

Re: Y70-70 Touch Laptop screen flicker

2017-05-03, 9:20 AM

Hello Pero231


Thank you for using the Lenovo forum


In this case it sounds like a hardware issue, i suggest contacting your local support team for technical help and a repair.


This is the link to the phone list where you can find these numbers


3811 Posts



2177 Signins

71411 Page Views

  • Posts: 3811
  • Registered: ‎12-24-2015
  • Location: IN
  • Views: 71411
  • Message 3 of 3

Re: Y70-70 Touch Laptop screen flicker

2017-05-04, 5:43 AM


In addition to Crosspython,


Ensure that your BIOS, Power Manager, GPU driver have been updated to the latest version available.


Right click on Desktop and select "Graphic Properties"

Select Power

Select Power Feature

In Graphics Power Plan Settings, change drop down menu to "On Battery"

Uncheck "Display Power Saving Technology"

Press "OK


Update us how it goes.







Tap that kudos button if I helped 
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"

Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop