Showing results for 
Search instead for 
Did you mean: 
Punch Card
Posts: 20
Registered: ‎09-05-2015
Location: CA
Views: 625
Message 1 of 3

Y70 battery is plugged in, not charging

At first, I use the conversation mode because I don`t use battery very often.

Today I find the battery is only 30% left while it should be 55-60%. Even I shut down this function, the battery still cannot charge.

I need to use the battery, but I can`t. A second time, Lenovo!

Sr Support Specialist
Posts: 9,503
Registered: ‎11-30-2015
Location: PH
Views: 610
Message 2 of 3

Re: Y70 battery is plugged in, not charging

HI Soleluv  , 





If the problem is triggered by new Windows update or changes on configuration , you may try this steps:


Step 1

First try power drain. 

Turn off , unplug the charger , remove the battery and press down the power button for 20 seconds. 

Restart and check for charging . 


Step 2

Else proceed uninstall Microsoft ACPI Compliant control method from Device Manager .  

Then restart. (click on highlight for detail step)


Step 3

Uninstall Energy Management from Programs and Features similar to this and restart .

Check if charging and then Install new updated version of the Energy Manager from the support site under Power Management component for your Windows version. 


With Li-based batteries , chemicals can go disarray / not evenly distibuted for utilization be that any battery manufacturer  that supplies to your model. 


None the less  , if this would happen to you often and that you have tried all 3 steps . 

Please call in tech support to best assist you to get things resolved within it's warranty coverage . 


Update us how things go for you. 




Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Punch Card
Posts: 20
Registered: ‎09-05-2015
Location: CA
Views: 602
Message 3 of 3

Re: Y70 battery is plugged in, not charging

For my issue, Step 2 has solved it. Thx!

Check out current deals!

Shop current deals

Top Kudoed Authors