Showing results for 
Search instead for 
Did you mean: 
Lenovo Staff
Views: 27,449


I cannot use my WiFi system to connect to any network. 


These were the things I did but could not fix the issue:


1. When I turned the WiFi physical switch to ON mode, the WiFi LED did not light up.


2. I saw this is a Atheros AR9285 wireless adapter from this place: Control Panel > Network and Internet > Network Connections


3. The Wifi icon still shows at the Taskbar, but just cannot pick up any network.


4. When I tried to install a new driver for the Bluetooth device, it notified me that I don't have any one. However, I still can send files via Bluetooth from my IdeaPad to other systems. What could be the problem?



  1. The Network Connections Windows shows that the device is installed with the correct driver. Otherwise a cross mark will appear to indicate that the device is not working.
  2. Also, the Bluetooth is actually working but is just not recognised by Windows.
  3. This means both your WiFi and Bluetooth are working, just that they may not be able to be activated by buttons or software.
  4. You may have missed out installation of the feature to activate WiFi and Bluetooth with Fn keys,  other than the physical switch for Wifi.



Did you install Power management? If not, please, install it first then press Fn +F5 to activate the wireless.


Was this information helpful?


I have Z470 and Wireless Network connection window keeps cycling between - Connecting - Limited Access - COnnected (no network access) and back to connecting.  My Fn-F5 key shows Lenovo Wireless Device settings.  I tried to download the latest windows 7 (64 bit driver) for Intel WiFi Link 1000 bgn wireless card and the Lenovo driver after downloading - I can not open and get an error that it is corrupted.  Any help will be greatly appreciated



There are a few possibilities or maybe more that i don't include here: 

1) you need to check if the password settings is correctly set up in your notebook. Let's say your router is using WPA2 PSK, you have to set the same in your computer. 


2) internet connection is not consistent


and many more.. You may want to create a discussion in the forum for other peers to help troubleshooting one by one for you.


Same problem here.


Just connects if I'm near wifi router.


If I am moving away 6 or 7 meters, the connection is lost.


I have tried to change energy settings, but, even configured to best performance (Windows 7), conecction is lost if I move away...


I have tried many modified drivers, but no success.


I think that Atheros 9285 is a bad hardware and we have no support for it.


A pity, because Z470 is a good notebook!


I called to Lenovo support.

I explained the sign lost if I move away more than 3 meters from the router.

Buddy answered me that Lenovo just serviced ensures up to 3 meters and still made me do a test, ping the system itself, i.e. to have 0 packet loss. If I had spoken q no more connection took 1 m, would say that only guarantee up to 1 metre ... joke ready like we say here!

Simply disappointing Lenovo post-sales and support!


This is reported on different occassions but very similar case.This is really frustrating that you dared commanding mark up prices to your notebooks worldwide compared to other top 5 PC vendors but almost have the same performance and issues.The quality and performance did not developed.This one i think is a flaw on the design and implementation process of drivers to this model that your manufacturing engineers have overlook and just catch up with the failure.Your engineers should have put a note or reminder regarding Energy Management on the wireless drivers that were posted in the drivers page to assist and prevent those consumers not techie enough who absorbed a lot of headache trying to figure out your crap wi-fi setup.Drivers installation and wireless setup should have been so easy. Everyday i'm updating drivers for various brands but your style is the most unhelpful. You make it so complicated even for an advanced user like me.Until now am still trying to figure out and research how can i make the wifi device detect the access point.I even dared to manually configure the AP but to no avail.Here's the model number of the LenovoIdeapad Z470 20094.I wish you won't igno re this complaint or else you will see your company sliding down below top 5 and nowhere.



Same problem here.

I have turned on both hardware switches found on the front side of the notebook. 

The WiFi LED in the center is turned on.

Wireless Network Card is turned on (through Fn+F5)

Network adapter is also enabled (Atheros ar9285)


With all these, my laptop could not still detect my wifi network.


To fix Z470 WiFi:


  1. Reboot
  2. [F2] and enter into BIOS
  4. Save and restart
  5. Done!



hi i need help, pls reply asap.     i updated my bios to the latest version after that my nvidia got error 43.. i dont know why so i reformated my laptop then install again my windows 7 64bit still have the same prob.. so i want to downgrade my bios cuz this version sucks alot!! i dont know where to get lower version. s there a way to bring back my bios version before the latest update?? thanks