cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
getsuga
Paper Tape
Posts: 4
Registered: ‎10-05-2014
Location: India
Views: 544
Message 11 of 13

Re: Z50-70 doesn't recognize my nvidia 840m graphic card with windows 8.1

I have same problem as OP from quite sometime and am pretty sure it is not drivers, I have tried on widows 7, 8.1 and 10 with all driver combinations and it never worked. Many times nvidia installer and windows don't detect the card like user lazygyz and on sometimes when they detect it crashes the entire system when used.

 

I abelieve it is due to a faulty bios update (most likely) or due to motherboard issue and not the end users.

 

Windows 10 is worst affected by this problem as it automatically installs the driver and gives blue screen on death on bootup. Then with safe mode I have to go to divice manager and disable it each time I install windows 10.

 

I would request bios and hardware engineers please look into this problem.

 

Currently I am using linux with their built in graphics driver, since card itself is not working properly, I have no reason to install a custom driver. Also it supports NVIDIA 840M (https://nouveau.freedesktop.org/wiki/CodeNames/)

 

Here is some output on linux

 

$ dmesg | grep "nouveau"
[   15.001102] nouveau 0000:03:00.0: enabling device (0006 -> 0007)
[   15.001247] nouveau 0000:03:00.0: NVIDIA GM108 (118010a2)
[   15.013758] nouveau 0000:03:00.0: bios: version 82.08.13.00.1b
[   15.098740] nouveau 0000:03:00.0: fb: 2048 MiB DDR3
[   15.098748] nouveau 0000:03:00.0: priv: HUB0: 6013d4 ffff573f (1f408200)
[   15.098807] nouveau 0000:03:00.0: bus: MMIO read of 00000000 FAULT at 10ac08 [ IBUS ]
[   15.098874] nouveau 0000:03:00.0: priv: HUB0: 10ecc0 ffffffff (1b40822c)
[   15.134437] nouveau 0000:03:00.0: DRM: VRAM: 2048 MiB
[   15.134439] nouveau 0000:03:00.0: DRM: GART: 1048576 MiB
[   15.134442] nouveau 0000:03:00.0: DRM: Pointer to TMDS table invalid
[   15.134498] nouveau 0000:03:00.0: DRM: DCB version 4.0
[   15.134500] nouveau 0000:03:00.0: DRM: Pointer to flat panel table invalid
[   15.251868] nouveau 0000:03:00.0: hwmon_device_register() is deprecated. Please convert the driver to use hwmon_device_register_with_info().
[   15.353473] nouveau 0000:03:00.0: DRM: MM: using COPY for buffer copies
[   15.353495] [drm] Initialized nouveau 1.3.1 20120801 for 0000:03:00.0 on minor 1
[   20.534003] nouveau 0000:03:00.0: DRM: evicting buffers...
[   20.534006] nouveau 0000:03:00.0: DRM: waiting for kernel channels to go idle...
[   20.534028] nouveau 0000:03:00.0: DRM: suspending fence...
[   20.537656] nouveau 0000:03:00.0: DRM: suspending object tree...
[   53.844068] nouveau 0000:03:00.0: DRM: resuming object tree...
[   53.928087] nouveau 0000:03:00.0: priv: HUB0: 6013d4 ffff573f (1f408200)
[   53.964766] nouveau 0000:03:00.0: priv: HUB0: 10ecc0 ffffffff (1e40822c)
[   53.965612] nouveau 0000:03:00.0: DRM: resuming fence...
[   60.348082] nouveau 0000:03:00.0: DRM: evicting buffers...
[   60.411800] nouveau 0000:03:00.0: DRM: waiting for kernel channels to go idle...
[   60.411826] nouveau 0000:03:00.0: DRM: suspending fence...
[   60.415501] nouveau 0000:03:00.0: DRM: suspending object tree...

 

 

I am willing to help in diagnosing the issue. Please help solving this bug!

cici2
Core Memory
Posts: 22
Registered: ‎01-29-2015
Location: AO
Views: 530
Message 12 of 13

Re: Z50-70 doesn't recognize my nvidia 840m graphic card with windows 8.1

Why you belive the problem is due to a faulty bios update? Try to update again the BIOS to last version, perform again clean Windows install, install chipset, Intel graphics and after Nvidia graphics.

Your Z50-70 is still under waranty? If afirmative and you will face same problem send it to service.

getsuga
Paper Tape
Posts: 4
Registered: ‎10-05-2014
Location: India
Views: 504
Message 13 of 13

Re: Z50-70 doesn't recognize my nvidia 840m graphic card with windows 8.1

Can you please read my post again, and previous people's comments? IF you do so you will see that op also had issue after that, and also that I have installed every edition of windows with all driver combinations (lenovo and manufcaturer sites).

No, problem occurred just one month after warranty period. Multiple people are having this issue and none of us have it resolved without replacing the system.

It would be great if someone passes this to actual developers. And if someone has link to original bios that shipped with this laptop, please give it to me.

Check out current deals!


Shop current deals

Top Kudoed Authors