Showing results for 
Search instead for 
Did you mean: 
What's DOS?
Posts: 1
Registered: ‎12-08-2014
Location: Phoenix, Arizona
Views: 1,885
Message 1 of 4

Z50-75 doesn't detect 2.5" SSD

I have the Lenovo Z50-75 and am attempting to upgrade the HDD to a Crucial M550 1TB SSD to no avail. The drive is not being detected on this machine, but it runs fine on my desktop. I've updated BIOS to v33 and tried both UEFI and Legacy settings with no luck. Is this model not compatible with SSD or maybe mine specifically?
Paper Tape
Posts: 1
Registered: ‎12-15-2014
Location: Bratislava
Views: 1,814
Message 2 of 4

Re: Z50-75 doesn't detect 2.5" SSD

I got same problem with crucial mx100 256GB and crucial mx550 125GB

samsung ssd is working fine

What's DOS?
Posts: 1
Registered: ‎01-05-2016
Location: Hampshire, UK
Views: 1,257
Message 3 of 4

Re: Z50-75 doesn't detect 2.5" SSD

Is this an AMD Z50-75?  If so I have a new A10 model and have the same problem.


I have tried both a Crucial MX200 and a SANDISK SSD in it and neither work.


I cloned the HDD using Acronis.  The cloned SSDs will work in other Laptops (e.g. my old Samsung). 


The Z50 is on the latest BIOS (2.09).


If I put the SSD into the HDD slot (under UEFI and AHCI) and then try to:


(a) boot from a Windows 10 boot media I get 'DRIVER_IRQL_NOT_LESS_OR_EQUAL (storahci.sys)' errors


(b) boot from a media and use Gparted then Gparted cannot see the SSD at all.


If I put the Z50 BIOS SATA mode to 'Compatable' then the SSD will sort of boot but it goes into an eternal cycle of Windows repairs.  I tried the 'recovery' option here too but the recovered image was also corrupt and cycled through the repair stage.


I have tried Crucial support who thought it might be a AHCI driver issue.


Lenovo support will not help with 'hardware modifications'.


Any ideas?

What's DOS?
Posts: 1
Registered: ‎05-04-2017
Location: PT
Views: 842
Message 4 of 4

Re: Z50-75 doesn't detect 2.5" SSD

I have about the same problem. I bought a new SSD device from crucial, installed it in a caddy on cd drive slot. It is recognized by bios but not by windows 10. SO I can't do either a copy or something else before to change disk drives.

My I have some hints. 


And we're back...

Move delayed but still coming

Learn More

Check out current deals!

Shop current deals

Top Kudoed Authors