cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
workingmum
Fanfold Paper
Posts: 6
Registered: ‎03-22-2015
Location: Nova Scotia Canada
Views: 736
Message 1 of 3

Z50 Bluetooth not working Windows 10

My bluetooth stopped working. All items in the driver were greyed out. So I downloaded the driver again. When it was complete I got the message" No appropriate Driver to be installed"

I have double checked to make sure I was downloading the driver for my laptop.

Any advice

Retired Support Specialist
Posts: 291
Registered: ‎01-16-2017
Location: GB
Views: 660
Message 2 of 3

Re: Z50 Bluetooth not working Windows 10



Hi workingmum,

 

Thanks for posting!

 

Can you confirm the unit is Z50-70?

Did you perform any updates prior to this issue occurring? Have you tried to uninstall the bluetooth driver from the Device Manager, reboot your unit and let Windows automatically reinstall it? If not, try that and see how it goes. 

 

I hope this helps and let us know how you get on.


----------------------------------------------------------------------------------------
Did someone help you today? Thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!

 

This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

workingmum
Fanfold Paper
Posts: 6
Registered: ‎03-22-2015
Location: Nova Scotia Canada
Views: 656
Message 3 of 3

Re: Z50 Bluetooth not working Windows 10

My Laptop is a Z50-70

I am not sure about updates - mine are automatic and I did not check.

I did try at you suggested: "Have you tried to uninstall the bluetooth driver from the Device Manager, reboot your unit and let Windows automatically reinstall it? If not, try that and see how it goes. "

Windows did not automatically reinstall

So I went thru the Lenovo website to find the driver for my laptop

Note: My laptop came with Windows 8 and I have upgraded to Windows 10. So I selected the driver for Windows 10.  After trying this couple of times, I realized the driver was in a folder under Windows8_OS (C):.

So I thought this might be my issue. So I uninstalled the driver for Windows 10 and installed the driver for Windows 8. It came up with an error message when it was complete - but it works.

 

Check out current deals!


Shop current deals

Top Kudoed Authors