cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
petergao1
Paper Tape
Posts: 3
Registered: ‎09-23-2018
Location: US
Views: 328
Message 1 of 6

Z51 80K6 AMD Card not Detected in Device Manager

Hi,

 

Recently I reset my PC and am now unable to find my AMD Radeon R9 M375 graphics card under device manager.

 

I tried to manually download the drivers, but my laptop gave me an "Error 173" and could not find the hardware.

 

I have changed the BIOS to use "Switchable Graphics" and the card still does not show up.

 

Any and all help would be appreciated.

Retired Support Specialist
Posts: 402
Registered: ‎08-02-2018
Location: US
Views: 293
Message 2 of 6

Re: Z51 80K6 AMD Card not Detected in Device Manager

Hi petergao1

 

Welcome to the Community Forums. 

 

The Radeon R9 M375 could be in the hidden devices. Go back to Device Manager, click View tab then select Hidden Devices. If Radeon graphics card shows up, right click it and uninstall. Restart your laptop. Access BIOS and load default settings. Reinstall the graphics card driver here, https://pcsupport.lenovo.com/us/en/products/laptops-and-netbooks/lenovo-z-series-laptops/z51-70. Update us how it goes.



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

petergao1
Paper Tape
Posts: 3
Registered: ‎09-23-2018
Location: US
Views: 290
Message 3 of 6

Re: Z51 80K6 AMD Card not Detected in Device Manager

Hello,

 

I set the view to include Hidden Devices, but my card still isn't displayed under the Display Drivers.

 

I tried the Lenovo Diagnostic Tools and it wasn't able to detect my card either.

 

Thanks

Retired Support Specialist
Posts: 402
Registered: ‎08-02-2018
Location: US
Views: 281
Message 4 of 6

Re: Z51 80K6 AMD Card not Detected in Device Manager

Have you tried setting the settings in BIOS to default? If not please do so. Also, do a power drain and observe.
https://support.lenovo.com/us/en/troubleshoot/lpt000352

 

Admin note: link shortener converted to full URL for clarity



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

petergao1
Paper Tape
Posts: 3
Registered: ‎09-23-2018
Location: US
Views: 275
Message 5 of 6

Re: Z51 80K6 AMD Card not Detected in Device Manager

Tried both "Load Default Settings" and doing a power drain.

 

Still no change, could it be a hardware issue?

Social Support Agent
Social Support Agent
Posts: 272
Registered: ‎08-02-2018
Location: US
Views: 259
Message 6 of 6

Re: Z51 80K6 AMD Card not Detected in Device Manager

We appreciate you trying the steps we've provided. Based on the error message you're getting, it is possible that the AMD Installer has detected that the current system does not contain AMD graphics hardware. It is best to have a technician check your device for further diagnosis and for repair if needed. You may bring it to Best Buy or any local technicians. Have a nice day ahead!



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Check out current deals!


Shop current deals

Top Kudoed Authors