Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
Community Spotlight

Visit the Lenovo Blogs!

Check out the ThinkPad Time Machine
Visit the Community Spotlight Blog
Windows  10

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
Reply
Highlighted
What's DOS?
Posts: 2
Registered: ‎02-27-2012
Location: Russia
0 Kudos

Z570 Windows XP ACHI driver doesn't work

Hi! 

 

I installed Windows XP on Lenovo z570 notebook.

It works ok in IDE mode, but when i try to install Intel AHCI driver from lenovo download page

 

http://consumersupport.lenovo.com/us/en/DriversDownloads/drivers_list.aspx?CategoryID=307140

 

it doesn't work. Seems it has not information about my hardware at all. File contains:

 

AHCI Controllers:
- Intel(R) 5 Series/3400 Series SATA AHCI Controller
- Intel(R) 5 Series 4 Port SATA AHCI Controller
- Intel(R) 5 Series 6 Port SATA AHCI Controller
- Intel(R) ICH10D/DO SATA AHCI Controller
- Intel(R) ICH10R SATA AHCI Controller
- Intel(R) EP80579 SATA AHCI Controller
- Intel(R) ICH9M-E/M SATA AHCI Controller
- Intel(R) ICH9R/DO/DH SATA AHCI Controller
- Intel(R) ICH8M-E/M SATA AHCI Controller
- Intel(R) ICH8R/DH/DO SATA AHCI Controller
- Intel(R) ESB2 SATA AHCI Controller
- Intel(R) ICH7M/MDH SATA AHCI Controller
- Intel(R) ICH7R/DH SATA AHCI Controller

 

and nothing about 

6 series/C200 Series chipset

 

Where can i get correct driver?

 

 

Retired Guru
Posts: 2,090
Registered: ‎07-13-2009
Location: USA
0 Kudos

Re: Z570 Windows XP ACHI driver doesn't work

Directly from Intel.
What's DOS?
Posts: 2
Registered: ‎02-27-2012
Location: Russia
0 Kudos

Re: Z570 Windows XP ACHI driver doesn't work

There's no such driver on intel.

Community Moderator
Posts: 13,431
Registered: ‎12-07-2009
Location: Česká Republika
0 Kudos

Re: Z570 Windows XP ACHI driver doesn't work

have you tried to change the settings in bios if there's an option?
( ide > ahci ) also, please, flash the bios update if you haven't already. it may help.

http://www.krasotaiskusstva.com