cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
robbymartin
Paper Tape
Posts: 7
Registered: ‎05-02-2013
Location: Yucaipa, CA
Views: 1,374
Message 1 of 4

Z580 - Battery plugged in but not charging.

For whatever reason, my Z580 is getting the "plugged in, not charging". This laptop is 2 months old and is too new to give me this problem.

 

I've tried:

1. Uninstalling the  Microsoft ACPI Compliant Control Method Battery but it just reinstalls after boot-up and I'm back to   square one. As long as I don't reboot it's fine but it automatically reinstalls. Is there an updated driver?

 

2. Removing the battery and holding the power button for 30-60 seconds, plug back in, yada, yada, yada...and still the same.

 

The only thing that seems to work is to plug it in and then open Lenovo Energy Management and somehow that kicks it into charging mode. It will take a 100% charge. I don't want to have to open Energy Management everytime I charge because its a hassle and thats unacceptable for a computer this new.

Retired Support Specialist
Posts: 481
Registered: ‎11-18-2012
Location: Egypt
Views: 1,325
Message 2 of 4

Re: Z580 - Battery plugged in but not charging.

Hi robbymartin,

 

Thanks for posting in the Lenovo Community,

 

I’d like to help you with the issue that you’re facing,

 

Could you please uninstall Lenovo Energy Management application from you application list and then restart the system,

 

Then please check the battery status if it will be plugged in Charging,

 

And then we will reinstall the application back.

 

Hope the information helps. Let us know.

 

Regards

 

Soha



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

robbymartin
Paper Tape
Posts: 7
Registered: ‎05-02-2013
Location: Yucaipa, CA
Views: 1,311
Message 3 of 4

Re: Z580 - Battery plugged in but not charging.

Soha,

I did as you suggested and nothing changed...still "plugged in, not charging."

 

With Energy Management uninstalled I can click the battery icon in the system tray and it kicks it into to charging. I've also noticed that occasionally if its "plugged in , not charging" and I leave it for several minutes it will begin charging as if it was on a delay, but that doesn't happen every time.

 

Anything else we can check?

kdub45
Paper Tape
Posts: 2
Registered: ‎07-27-2017
Location: US
Views: 194
Message 4 of 4

Re: Z580 - Battery plugged in but not charging.

I'm having the same issue, have you found a solution? I have a new battery installed (purchased through Lenovo 3rd party site) and still same issue.

 

Can anyone help with this?

Check out current deals!


Shop current deals

Top Kudoed Authors