cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
cdlune
Paper Tape
Posts: 2
Registered: ‎12-13-2012
Location: S. Korea
Views: 5,517
Message 1 of 5

ideapad Z585 UEFI boot issue

Well, I got a BIOS update (version 93) from Lenovo Support and updated BIOS from version 92 to 93.

After update, system does not boot on a primary SATA disk with pure UEFI boot setting.

 

And my laptop does not display the fancy BIOS POST checking screen with progress bar, but black screen.

About 10 secs later it displays boot device selection menu.

When I select a primary SATA hard disk drive, it does not boot and displays boot device selection menu again and again.

 

So I disabled pure 'UEFI' and enabled 'Legacy Support', set the priority as 'UEFI First',

then everything works fine. Windows 8 x64 boots correctly on UEFI mode, but pure UEFI boot does not work.

 

On Version 92, pure UEFI boot worked without any problems.

I wonder why does it happens. Is there anyone who have some clues of this problem?

 

* P.S. If anyone has same problem like me, I recommend try my solution first.

Social Support Agent
Social Support Agent
Posts: 5,824
Registered: ‎02-11-2012
Location: PH
Views: 5,437
Message 2 of 5

Re: ideapad Z585 UEFI boot issue

hi cdlune,

 

Welcome to the Lenovo Community.

 

When the computer turns ON, it goes to the following procedure:

 

P.O.S.T > OS Loader > EFI > Firmware > Hardware

 

The EFI data table probably doesn't match the information from your new BIOS firmware v93 and it must be reading Boot Table Configuration from your old BIOS v92. When this check fails, it will not call the OS loader to startup Windows. A similar issue was started here

 

What you can try is to reset the BIOS to default (Press F9 to Load the default configuration and F10 to save and exit BIOS). If this doesn't work, you will need to permanently disable EFI (by enabling Legacy Support)

 

More Information here:

1. How UEFI works

2. UEFI - FAQS & Overview

 

 

Hope this helps.



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Woltanac
Fanfold Paper
Posts: 5
Registered: ‎11-23-2012
Location: Indiana
Views: 5,403
Message 3 of 5

Re: ideapad Z585 UEFI boot issue

Thank you for posting this information.  The same thing happened to me on my z585.  I followed your steps and Windows 8 booted.  Unfortunately, I have some serious problems with Windows 8 now.

 

When Windows 8 booted for the first time, I receieved an error that AMD Quick Stream was not licensed to my computer.  Also, a Windows Action Center message pops up saying Windows 8 isn't activated anymore.  (Error code 0xC004C008:  The activation server reported that the product key has exceeded its unlock limit.)  Evidently, something changed in the BIOS to make Windows 8 think this is a different laptop. 

 

My new post is here: 

 

http://forums.lenovo.com/t5/IdeaPad-Y-U-V-Z-and-P-series/Windows-8-deactivated-after-BIOS-version-93...

Balie78
What's DOS?
Posts: 5
Registered: ‎01-17-2013
Location: Budapest
Views: 5,244
Message 4 of 5

Re: ideapad Z585 UEFI boot issue

Thank you both! This one got my heart stopped for a minute.... I normally do not tempt my luck with BIOS updates, but ocasionally had Windows boot issues, and this one promised to fix those. So, after getting through the cumbersome Win8 reactivation thing i am up and running. However i find the Lenovo response to Woltanac's call ridiculous. If BIOS refresh is illegal, do not make it a public download, or better yet, make a product that doesn't need an update... And if the Win8 upgrade voids the warranty, somwone should make a class action against Lenovo, as they advertised and refunded the upgrade...
cdlune
Paper Tape
Posts: 2
Registered: ‎12-13-2012
Location: S. Korea
Views: 3,577
Message 5 of 5

Re: ideapad Z585 UEFI boot issue

This problem (UEFI boot issue) has been solved via installing Windows on GPT disk.

Now I can boot Windows via UEFI Smiley Happy

 

If you want to boot via pure UEFI, you must convert your disk from MBR to GPT disk with DISKPART first.

(In order to convert your disk, you have to clean all of partitions)

Check out current deals!


Shop current deals

Top Kudoed Authors