cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
LenBlazer
Bit Torrent
Posts: 5,332
Registered: ‎05-09-2013
Location: US
Views: 1,988
Message 31 of 35

Re: msata drive not visible in Disk Management - Windows 8.1 Lenovo y510p


@ColonelONeill wrote:
Quote from http://forum.notebookreview.com/solid-state-drives-ssds-flash-storage/732726-ssd-suggestion-lenovo-y... :

"We have one here in a y510p but only using it as a cache drive. It was recognized by express cache and fnet. I will check the BIOS and try a fresh win 8 install from scratch to see if there are any tricks to it.

Update: Ok here you go

In your BIOS, under Boot, change Boot Mode to Legacy Support, and change the Boot Priority to Legacy First, then exit saving changes and go back into the BIOS. Now under the Boot menu you should have a boot order on the bottom of that boot window.

MyDigitalSSD "

Read message 7.

jacksonmacd
Fanfold Paper
Posts: 18
Registered: ‎11-23-2014
Location: CA
Views: 1,981
Message 32 of 35

Re: msata drive not visible in Disk Management - Windows 8.1 Lenovo y510p

That article was slightly different than what I've seen before, but still no success.

 

Booting second time into BIOS was the new informationt, and indeed, I can control the boot order of the two disks when both disks are installed in the computer. But the net result is the same - O/S is unable to see the SSD. Tried from both a live Linux CD (GParted) and with a disk image managed by Macrium Reflect.

 

Regarding the link in your message:

http://forum.notebookreview.com/solid-state-drives-ssds-flash-storage/732726-ssd-suggestion-lenovo-y... :

 

The SSD that I purchased (ADATA Premier Pro SP900 SATA M.2 2242 SSD) looks identical to the one in the first photo. The Crucial SSD in the second photo will not fit - it has two mounting screw holes that will not align with the single screw on the motherboard.

 

The thread ended with a question about whether to purchase the Cache version or the Boot version of the SSD. There was no reply. I am beginning to think that's the real issue -- could there be two versions of the M.2 SATA SSD, and I happen to have the wrong one?

 

Then looking at:

https://www.ramcity.com.au/blog/m.2-ngff-ssd-compatibility-list/189?&ship_country=CA

 

which states that the Lenovo Y510P is compatible with the SATA 42mm M.2 NGFF compatible systems (2242). 

I get the feeling that means physically-compatible, and the SSD I purchased does indeed fit in the slot. The article also mentions M.2 SATA versus M.2 PCIe; I don't understand the difference, but I my SSD is labelled "SATA", and I haven't seen any documentation that the Y510P requires PCIe. Everything I've seen implies the Y510P uses SATA.

 

LenBlazer wrote that the article also said the port was only useable for caching purposes; I can't see where that is stated in the article, and I've seen other contradictory information. For example, this article (linked below) about a particular SSD states that it's compatible with the Y510P, and can be used as either a cache (default) or boot drive. It looks identical to my SSD, but its name includes the phrase "Super Cache". It makes me think that's a crucial distinction that I was not aware of when I purchased the SSD. Perhaps the difference is with the SSD itself, and not with the computer?

 

http://www.mydigitaldiscount.com/mydigitalssd-128gb-super-cache-2-sc2-42mm-sata-iii-6g-m.2-ngff-ssd-...

 

I appreciate all the help everyone has supplied, and I don't mean to be a PITA, but the information and experience is really confusing. I want to believe your article that an SSD can be either a cache or drive in the Y510P, but there is no indication that it was ever installed successfully. 

 

I think I will admit defeat and return the SSD for refund.

 

Guru
Posts: 9,598
Registered: ‎12-26-2009
Location: CA
Views: 1,950
Message 33 of 35

Re: msata drive not visible in Disk Management - Windows 8.1 Lenovo y510p

It's possible the SSD you got is defective. Hard to diagnose without another system known to work with M.2 SSDs.

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
sharky25k
Paper Tape
Posts: 5
Registered: ‎08-09-2014
Location: Prague
Views: 1,896
Message 34 of 35

Re: msata drive not visible in Disk Management - Windows 8.1 Lenovo y510p

Hello to everybody,

 

I had the same problem in august when I was trying to install windows 8 or windows 8.1 on my mSATA SSD (the same model as described in the first post) on a lenovo y510p.

 

However, how i desribed in this topic, I was unable to install windows 8 or 8.1 on the SSD. The  only way which the W8 was installed on SSD, was to put the SATA controller on compatibility mode. For obvious reasons I don't want to use an SSD drive on compatibility mode, since I have a slower speed than in AHCI. Using the W7 setup I was able to install it without having those annoying errors which are mentioned also in this topic. Windows 7 worked also in UEFI or standard BIOS mode. W7 setup worked also with MBR or GPT partition table. So probably there is a problem in configuration of the PC and W8 setup compatibility.

 

The lenovo machine is used by my girlfriend and since I study abroad, I don't have access to this computer (and I would not try it either since it is set up and I don't have time to create backup and experiment with it) but I would recommend to somebody who is using the computer to try to make a USB setup disk for w8 and put in the ROOT of the USB setup drive (without any separate folder) the drivers for the Intel SATA controller (as I remember it was some intel driver) and try to run the setup of w8 to see if it works.

 

The suggestion came into my mind for a simple reason. I am also testing W10 on an old computer (Acer laptop) from 2008 and I never had problems to install on it windows XP (in SATA compatibility mode of course) or Windows 7 (in AHCI mode). However, when I tried W10 setup I got the same problem as on the lenovo machine... (strangely enough since there is no mSATA port just a simple normal HDD on SATA). Because I did not have any other USB drive (to put on the drivers on it to add them manually when I get to the list of HDD in setup) I placed the drivers on the setup USB but by mistake I placed the files for drivers directly on ROOT (no other separate folder) and it worked like a charm, the setup did not ask for any drivers when I got to the list of drives, I was able to initialize the drive and install w10 without any problem. Without the drivers placed in the root of the USB drive with setup I was unable to format or install the w10 on my HDD.

 

It is true I had this experience on W10 setup but probably it will work also for w8 in case of the lenovo y510p with a mSATA SSD.

 

If anyone will try this please come back with a feedback.

I strongly believe that this has to do with some drivers which are used by the setup since W7 works flawlessly.

 

Best regards,

Treitli Sebastian

 

PS: Put the drivers files not the setup file (not the .exe files). I mean the .sys and .dll files specific for your setup configuration (x32 or x64).

PVTD
Paper Tape
Posts: 1
Registered: ‎06-16-2015
Location: Earth
Views: 1,726
Message 35 of 35

Re: msata drive not visible in Disk Management - Windows 8.1 Lenovo y510p

FIXED!

Ok, I struggled with about 90% of what people have in this thread.

I figured a way to actually make it work thanks to puzzeling a bit in various forums and trying over and over with different solutions.

 

First of all, I have the unlocked BIOS on the Lenovo Ideapad Y510P so I could upgrade the WiFi card to a Intel Dual Band AC 7260.

You can find the info on how to here: Techinferno unlock Whitelist BIOS

 

I upgraded my SSD from the rediculous 20gb card to a 128gb (it's the only m.2 card I could find in my region without having to wait 2 months)

 

So, I installed it and like other people said, it showed up and it dissapeared and bla bla, all the ghost simptomes.

I went into the unlocked BIOS and found the new SSD listed fine, but went to slot 4 (the m.2 slot) and set it to "Solid State Drive" no idea what that does as it worked fine as "Hard Drive" but hey, it might have helped!

I went back into windows and we had the classic "no file specefied found" thing, so no luck.

 

Another person mentioned Boot It Bare Metal, but had no reaction to it, so I tried it, installed it on a USB drive and started it up. (Find it here 30 day trial, enough to create a new partition)


Once started it asks you to install it on a hard drive, just say no and a pop up appears with some data about your main HDD or SSD, select the new SSD you selected (Any other partition software or Live CD didn't detect it) and create a new partition.

Once done, boot back into Windows, Disk Managment, wait a bit and the SSD will appear.

Right click it and WOOT! the "Create Partition" is BACK!!!

Create a new partition, press the next button exitedly and VOILA! it's working after the format!

 

It might show that you have another same SSD, but just reboot and it will list perfect again.

 

Any doubts or questions, I will subscribe to this thread.

Check out current deals!


Shop current deals

Top Kudoed Authors