cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
sirchbuck
Fanfold Paper
Posts: 4
Registered: ‎06-16-2013
Location: Kuwait
Views: 1,156
Message 1 of 7

proper ATI display drivers required

I havev an ideapad y560  with an ATI raedon HD 5370
I had performed a fresh windows install a while back and continued to install the display drivers, i tried the look for the drivers but can't seem to find the exact version that came with the laptop, the drivers page for listed an ATI display driver only available for windows XP there weren't anyother viable options.

I would appretiate it if someone were to give me the link for the correct driver. 

Retired Support Specialist
Posts: 4,447
Registered: ‎04-22-2013
Location: Philippines
Views: 1,126
Message 2 of 7

Re: proper ATI display drivers required

hi sirchbuck,

 

You might want to check the drivers directly from ATI

Lenovo Drivers on Support site is only limited to what OS that came with your system.

 

You can check ATI here

http://support.amd.com/us/gpudownload/Pages/index.aspx

This are the options you must select

Untitled.jpg

 

Hope this helps,

Cheers!



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

sirchbuck
Fanfold Paper
Posts: 4
Registered: ‎06-16-2013
Location: Kuwait
Views: 1,112
Message 3 of 7

Re: proper ATI display drivers required

I selected the correct options and was directed to a download page with 2 options, AMD Catalyst 13.6 Mobility Beta2 and the automatic driver detection tool, i selected the beta drivers.
After installing it, I received a blank black screen after the black starting windows screen.
Further ,
I tried opening the AMD catalyst control Center in safe mode and I encountered the a 'MSVCR110_CLR0400.ddl is missing' error

Retired Support Specialist
Posts: 4,447
Registered: ‎04-22-2013
Location: Philippines
Views: 1,101
Message 4 of 7

Re: proper ATI display drivers required

hi sirchbuck,

 

The Catalyst may not work under safemode, safemode is restricted for minimum Software/driver

 

On your driver page Im seeing download for ATI for windows XP and 7.

have you tried using these drivers see if it will work.

 

Uninstall the current under control panel and device manager then download and install any of the two as per your OS.

 

Windows 7 ATI Driver

IN4VDO08WW5.exe
326MB

 

Windows XP ATI Driver

IN1VDO02WW1.exe
176 MB

 

Solid Cruver

Cheers!



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

sirchbuck
Fanfold Paper
Posts: 4
Registered: ‎06-16-2013
Location: Kuwait
Views: 1,085
Message 5 of 7

Re: proper ATI display drivers required

After downloading it I still get the same black screen problem.
Ironically it is the same exact driver that someone kept for me after I performed a fresh windows install

sirchbuck
Fanfold Paper
Posts: 4
Registered: ‎06-16-2013
Location: Kuwait
Views: 1,052
Message 6 of 7

Re: proper ATI display drivers required


After some searching i found out what was preventing me from booting successfully
This thread here has the solution

http://forums.lenovo.com/t5/IdeaPad-Y-U-V-Z-and-P-series/ideapad-y560-radeon-5730-black-screen-need-...


, apparently there are some problems with the power options/energy management, what ever.The computer would open and work fine (with the driver you gave me) if I open it running solely on the battery and not connected by the power cord. Everything seems normal 

Graphically utilized softwares would run normally,the screen runs at native resolution etc.
However as soon as I plug in the power cord it would freeze (or perhaps refresh at less than 1Hz and then gradually completely freezes if that makes sense) 

After looking at the instructions in that thread:-
------------------------------------------------------------------------------
"
i had to adjust the energy settings in windows. the mininmal performance is set to 100 percent for running with cable. if you set it to 5% like running on battery, it isnt crashing. perhaps this could be a solution to other having the black screen after windows logo.

here's what to do:
boot in safe mode and adjust your energy settings for running with ac adapter. set the minimal performance to 5%"
--------------------------------------------------------------------------------
so I got kinda confused here i assume he is talking about the processor power management settings
So running normally i set the minimum processor state to 5% for 'Plugged in' (All inside the high performance preset which i assume will be loaded at startup)I restarted with the powercord on, still got a black screen. 
So off to safemode, 
"adjust your energy settings for running with ac adapter. set the minimal performance to 5%" 
from what I can interpret, it seems like there's a specific option inside the minimum processor state ( on battery and plugged in) 
however there is only one option (percentage) I think it's global for both. 
It is set to 5%. 

I am just one step away.... 

zypper2002
Ctrl-Alt-Del
Posts: 24
Registered: ‎06-24-2013
Location: Saudi arabia
Views: 1,017
Message 7 of 7

Re: proper ATI display drivers required

Did it work on your laptop adjusting the power management?
Where can i find that setting?

Check out current deals!


Shop current deals

Top Kudoed Authors