cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
justusername
Paper Tape
Posts: 4
Registered: ‎06-17-2015
Location: Romania
Views: 595
Message 1 of 7

y50-70 - Updated BIOS, now the screen flashes red.

So I just got my Lenovo y50-70 which is quite expensive (very) in my country.

 

All great. They said the screen had a red subpixel blocked and I said "Sure, no problem!".

 

All went great, until I updated the BIOS to 2.01 I believe.

 

Then it all turned to hell and it stayed that way. The screen flashes red, it has a latency of 0.5s (aka, if I do something, it displays the image that was on there 0.5 seconds ago - lag, in other words), I really can't see much (it is hard to).

 

And ofcourse, in my country, the support is closed right now, so I can't ship it back.

 

I really need somebody to tell me what the default / original version of the BIOS on Lenovo y50-70 (i7 4720HQ, Geforce GTX 960M), I've searched for so long, but nothing popped up.

 

OR any other ideas to revert back?

 

Please and tank you.

justusername
Paper Tape
Posts: 4
Registered: ‎06-17-2015
Location: Romania
Views: 580
Message 2 of 7

Re: y50-70 - Updated BIOS, now the screen flashes red.

Since threads almost never get replies...

 

$20 for the one who gives me the answer (via PayPal).

 

Sorry - but this is very frustrating to me.

LenBlazer
Bit Torrent
Posts: 5,332
Registered: ‎05-09-2013
Location: US
Views: 570
Message 3 of 7

Re: y50-70 - Updated BIOS, now the screen flashes red.

I think that's the only available bios for your unit. After the update, did you set everything to default values? If not, try going into the bios and reset everything to default values. Then save and exit.

 

justusername
Paper Tape
Posts: 4
Registered: ‎06-17-2015
Location: Romania
Views: 566
Message 4 of 7

Re: y50-70 - Updated BIOS, now the screen flashes red.

Yes, yes and again, yes.

 

Yes Smiley Happy

 

Now WIndows says that my 960m (GTX) doesn't work properly, but I installed the drivers I installed some time ago (which worked).

LenBlazer
Bit Torrent
Posts: 5,332
Registered: ‎05-09-2013
Location: US
Views: 556
Message 5 of 7

Re: y50-70 - Updated BIOS, now the screen flashes red.


@justusername wrote:

Yes, yes and again, yes.

 

Yes Smiley Happy

 

Now WIndows says that my 960m (GTX) doesn't work properly, but I installed the drivers I installed some time ago (which worked).


Try uninstalling it completely and reinstall. Or you can try using an older version if there are any.

justusername
Paper Tape
Posts: 4
Registered: ‎06-17-2015
Location: Romania
Views: 555
Message 6 of 7

Re: y50-70 - Updated BIOS, now the screen flashes red.

I tried everything humanly possible.

 

Uninstalled the drivers, everything, reinstalled three different versions. Windows just doesn't recognize it anymore. (The video card).

Even used DDU / Reinstalled Windows (FULL FORMAT!)

 

I'm waiting for a "wonder answer"...

 

This is insane, I just installed what Lenovo recommended.

LenBlazer
Bit Torrent
Posts: 5,332
Registered: ‎05-09-2013
Location: US
Views: 546
Message 7 of 7

Re: y50-70 - Updated BIOS, now the screen flashes red.


@justusername wrote:

I tried everything humanly possible.

 

Uninstalled the drivers, everything, reinstalled three different versions. Windows just doesn't recognize it anymore. (The video card).

Even used DDU / Reinstalled Windows (FULL FORMAT!)

 

I'm waiting for a "wonder answer"...

 

This is insane, I just installed what Lenovo recommended.


Then your only choice is to call Lenovo for a possible repair.

Check out current deals!


Shop current deals

Top Kudoed Authors