English Community

Lenovo NotebooksLenovo P, Y and Z series Notebooks
All Forum Topics
Options

1 Posts

02-05-2020

US

1 Signins

10 Page Views

  • Posts: 1
  • Registered: ‎02-05-2020
  • Location: US
  • Views: 10
  • Message 1 of 8

y50 Won't Charge, or charges/discharges

2020-02-05, 16:36 PM

Hi. I recently replaced a power supply. Also replaced the motherboard. The computer will charge now if not on. Before, it gradually failed, to the point it wouldnt charge at all. 

 

Current symptoms - blinking white and amber lights, and power button while plugged in.  If i plug it in, while in windows 10, it will quickly cycle from charge -no charge - charge - then remain not charging with the afformentioned lights. Computer operates on the (weak) battery.

While off and charging, the white light is solid, but will blink every 5 seconds. 

 

Other steps taken: Ive reinstalled drivers, attempted to install windows 8.1 lenovo power manager. Also, i used an incorrect charger before that ended up frying a board (unknown) that was replaced by lenovo. 

 

Ill try replacing the dc in cord, but not too confident about it being the problem. Any suggestions would be greatly appreciated! 

Reply
Options

445 Posts

11-04-2019

US

169 Signins

12767 Page Views

  • Posts: 445
  • Registered: ‎11-04-2019
  • Location: US
  • Views: 12767
  • Message 2 of 8

Re: y50 Won't Charge, or charges/discharges

2020-02-05, 17:33 PM

 

Welcome to the Community Forums quickmilbucks!

 

Nice to have you here!

 

Can you please provide your laptop's machine type-model/MTM number for us to check its specifications?

 

Also, does the charger also works on other laptops?

 

We'll be waiting for your response.

 

Thanks!

Adriel_lenovo

 



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Reply
Options

1 Posts

02-05-2020

US

1 Signins

10 Page Views

  • Posts: 1
  • Registered: ‎02-05-2020
  • Location: US
  • Views: 10
  • Message 3 of 8

Re: y50 Won't Charge, or charges/discharges

2020-02-05, 18:20 PM

Model number 20378

Reply
Options

445 Posts

11-04-2019

US

169 Signins

12767 Page Views

  • Posts: 445
  • Registered: ‎11-04-2019
  • Location: US
  • Views: 12767
  • Message 4 of 8

Re: y50 Won't Charge, or charges/discharges

2020-02-05, 18:34 PM

 

 

Hi quickmilbucks!

 

Thanks for providing that information.

 

Since you've mentioned that you've replaced some parts on your Y50-70 laptop, try to check if the clip from the battery to the board has become loose. 

 

Please see page 36 of your laptop's hardware manual to see the steps on how to check it.

 

Also you may click the links below to check previous posts from other users who have also encountered this issue to see the steps that they've performed.

 

Y50-70 not charging - click here

Y50-70 connected but not charging - click here

 

Let us know what will happen.

 

Thanks!

Adriel_lenovo

 



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Reply
Options

1 Posts

02-05-2020

US

1 Signins

10 Page Views

  • Posts: 1
  • Registered: ‎02-05-2020
  • Location: US
  • Views: 10
  • Message 5 of 8

Re: y50 Won't Charge, or charges/discharges

2020-02-05, 19:07 PM

 Battery is plugged in. New adapter, i have no way of testing it on another laptop. Initially i didnt notice the problem though it was on for several hours. Not sure if it developed or was like that from first use. Also, Before the motherboard was changed, the symptoms were the same.

Reply
Options

445 Posts

11-04-2019

US

169 Signins

12767 Page Views

  • Posts: 445
  • Registered: ‎11-04-2019
  • Location: US
  • Views: 12767
  • Message 6 of 8

Re: y50 Won't Charge, or charges/discharges

2020-02-06, 17:26 PM

 

 

Hello again quickmilbucks!

 

Thanks for the response!

 

 

Based on the description that you have provided, it would be also best to check your laptop's Power Board since you mentioned that the laptop charges properly still when it is off but not when it's turned on (active).

 

You may use the part number 5C50F78789 if in case the Power Board itself may needs to be replaced as well.

 

 

Thanks!

Adriel_lenovo

 



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Reply
Options

1 Posts

02-05-2020

US

1 Signins

10 Page Views

  • Posts: 1
  • Registered: ‎02-05-2020
  • Location: US
  • Views: 10
  • Message 7 of 8

Re: y50 Won't Charge, or charges/discharges

2020-02-08, 17:17 PM

Thanks. I'm attempting to order that part - a bit hard to find.

 

An update - i updated the Bios. I installed windows 8.1 and all mobo drivers. Flashing lights changed a bit. When intially plugged in, it will show a charge for a bit longer, then back to flashing. Same as before - need to shut down, reinsert plug and it will charge to full battery until started. As bios is loading, it begins to flash. 

Reply
Options

1 Posts

02-05-2020

US

1 Signins

10 Page Views

  • Posts: 1
  • Registered: ‎02-05-2020
  • Location: US
  • Views: 10
  • Message 8 of 8

Re:y50 Won't Charge, or charges/discharges

2020-03-07, 13:15 PM

I replaced the powerboard. The computer ran for several hours, similar to after changing the motherboard. I shut down. next time starting the symptoms continued. I have removed the battery and it will not start without it, when plugged in. Instead it "blips" on for a second and shuts off. Now not charging while off. I get synchronized power, amber and white lights cycling on every 5 seconds or so.Its a confusing problem. any advice would be appreciated.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete