cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Xanek
Punch Card
Posts: 71
Registered: ‎10-22-2011
Location: Texas
Views: 2,033
Message 21 of 53

Re: y570 sound problems (some annoying noise)

Sorry for bumping this thread instead of creating a new one, but I am having the same problem too, but I have already tried geo_lion03's solution.
It does work and eliminate the problem, but it also gets rid of the SRS Surround sound.
I have tried GreatCornMuffin's solution and it does work well but it eliminates some of the surround sound, only a bit.
Is there a way to not do that method but eliminate the actual annoying static noise that changes depending on the application being used?

Note that Realtek's audio drivers on their website (the more up to date ones than on lenovo's, still have this problem)
Morri
Paper Tape
Posts: 2
Registered: ‎11-21-2011
Location: Russia
Views: 1,987
Message 22 of 53

Re: y570 sound problems (some annoying noise)

It works. Still, its better not to use headphones (i can hear this noise only in headphones) than not to use wi fi card. Also, uninstalling realtek audio driver helped to solve this problem (well, in my case it helped).
geo_lion03
Punch Card
Posts: 22
Registered: ‎10-20-2011
Location: us
Views: 1,868
Message 23 of 53

Re: y570 sound problems (some annoying noise)

yes uninstalling the realteck drivers seams to solve the noise problem, deconnect the wi fi works also , but we don t wont to uninstall the realteck driver and srs because the sound becomes very bad without srs and realteck drivers installed , they must find a solution  , because is a drivers issue this is for sure .... why the version that i put the link above don t have the noise ... ???? 

Highlighted
geo_lion03
Punch Card
Posts: 22
Registered: ‎10-20-2011
Location: us
Views: 1,743
Message 24 of 53

Re: y570 sound problems (some annoying noise)

one thing also , try to use with a powerfull speackers also , and you will have a simphony noise , in headphones the noise is acceptable , but in case of some powerfull speackers belive me that is very bad the noise , my older laptop was an asus , and wasn t having this problem at all , and was realteck also... line out checking , don t help so much , i love this laptop but i m angry about this problem , and what i m angry the most is that the lenovo don t seams to make any research about , and what i have seen is that most lenovo laptops have this problem and nothing... really??!! 

Sfairat
802.11n
Posts: 145
Registered: ‎08-04-2011
Location: Odessa, Ukraine
Views: 1,727
Message 25 of 53

Re: y570 sound problems (some annoying noise)

So, at last, I figured out the source of this problem, and it is fully described there http://leshcat.blogspot.com/2010/12/realtek-hd-audio-driver-static-noise.html .

It may sound a bit weird, but really, though in new realtek drivers available at lenovo support website pc beep option is hidden, it is actually enabled, and, it looks like that its volume level is set too 100%. I figured it out in a following way: I installed the drivers proposed at the link aboveand had no problem with static noise(pc beep option is disabled by default for them), then I tried to unmute that pc beep option, and heard familiar noise during wifi activity. The only problem with these drivers is that SRS is incompatible with them, so they're not better than original win drivers =(

So, here is my question to people from Lenovo staff: can you please escalate this issue to engineering so they will publish new version of realtek drivers with pc beep option not hidden? It must be easy, because it is actually present, but only hidden, and that static noise is REALLY, REALLY annoying.

Fletchman1313
Token Ring
Posts: 117
Registered: ‎03-04-2011
Location: Hawaii
Views: 1,714
Message 26 of 53

Re: y570 sound problems (some annoying noise)

I just purchased a Y570 and I don't seem to have this problem.  So it could be that the "newer" units have been fixed.  I did have to tweak the EQ a bit because I thought the highs were too high, but other than that I don't have any kind of static or humming noise.

 

As the days/weeks go on, I'll post an update and the resolution here (if any).

geo_lion03
Punch Card
Posts: 22
Registered: ‎10-20-2011
Location: us
Views: 1,706
Message 27 of 53

Re: y570 sound problems (some annoying noise)

we are talking about static noise in the output jack , i also use it hdmi and not strange noise the only problem is the jack output , have you try it on output jack some external speakers , not the internal one they are fine to me ...?
geo_lion03
Punch Card
Posts: 22
Registered: ‎10-20-2011
Location: us
Views: 1,705
Message 28 of 53

Re: y570 sound problems (some annoying noise)

yes this is what i m questioning also , i also send a mail to realteck but after 3 weeks no response . lenovo also no response to the mail since they are saying there that give us 48 hours to respond to your mail... really , it s passed one month.
Fletchman1313
Token Ring
Posts: 117
Registered: ‎03-04-2011
Location: Hawaii
Views: 1,700
Message 29 of 53

Re: y570 sound problems (some annoying noise)

I tried it through headphones too, and didn't get any static.  I haven't tried an HDMI connection yet but I'll try that soon.

Retired Moderator
Retired Moderator
Posts: 13,719
Registered: ‎12-07-2009
Location: CZ
Views: 1,688
Message 30 of 53

Re: y570 sound problems (some annoying noise)

Check out current deals!


Shop current deals

Top Kudoed Authors