cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
radicalg
Paper Tape
Posts: 7
Registered: ‎07-29-2012
Views: 36,778
Message 1 of 52

z580 can't access bios setup or boot menu after changing to Legacy from UEFI mode

The problem started when i changed to legacy mode when windows installation started giving me trouble.
What i think would fix the problem is to either change back to UEFI mode from windows, or to get in the BIOS menu somehow..
Does anyone know how to do either of those things? any other ideas are more than welcome Smiley Happy

radicalg
Paper Tape
Posts: 7
Registered: ‎07-29-2012
Views: 36,603
Message 2 of 52

Re: z580 can't access bios setup or boot menu after changing to Legacy from UEFI mode

Anyone? u_u

I was under the impression this community contained some Lenovo experts..

countrywise
Broadband 3G
Posts: 828
Registered: ‎04-14-2012
Location: İstanbul
Views: 36,573
Message 3 of 52

Re: z580 can't access bios setup or boot menu after changing to Legacy from UEFI mode

No Lenovo expert me,

 

however have you pressed f2 after the Lenovo logo appears?

 

 

http://www.lenovo.com/shop/americas/content/user_guides/z380_z480_z580_z585_ug_en.pdf

 

 

radicalg
Paper Tape
Posts: 7
Registered: ‎07-29-2012
Views: 36,545
Message 4 of 52

Re: z580 can't access bios setup or boot menu after changing to Legacy from UEFI mode

Thank you for the reply,
Yes, i did. but there is no reply whatsoever.. It would just boot windows.
The thing is, the same thing happens when i boot using the NOVO button.. any option i click boots windows.


countrywise
Broadband 3G
Posts: 828
Registered: ‎04-14-2012
Location: İstanbul
Views: 36,529
Message 5 of 52

Re: z580 can't access bios setup or boot menu after changing to Legacy from UEFI mode


@radicalg wrote:

The problem started when i changed to legacy mode when windows installation started giving me trouble.


Please give more details as to the original OS,

the current system you're using,

 

what kind of trouble was Windows giving you?

 

Have you tried a repair install via the Windows System Repair disc,

 

and /or via  Safe mode?

 

Have you tried pressing  f12?

radicalg
Paper Tape
Posts: 7
Registered: ‎07-29-2012
Views: 36,522
Message 6 of 52

Re: z580 can't access bios setup or boot menu after changing to Legacy from UEFI mode

Alright the full version it is;

I just got the laptop, and it was in freedos. Whenever i tried to install windows, it gave me errors regarding the OEM partition, since i formatted the disk to eliminate it.
I looked up a solution, and it said disable UEFI boot mode in the BIOS menu and install windows normally. So I did. However, later on, when i tried to boot from my Ubuntu USB drive, the BIOS menu wouldn't come up, nor would the boot menu. I clicked every key possible, and every combination possible and it still wouldn't.

My problem now isn't with windows 7, it runs perfectly... my problem is solely with the BIOS. It would not let me in menu. It just boots Windows every time I try to get in.
I tried everything.. will i have to flash the BIOS? I couldn't even find the driver for that online (nor on the driver CD i got with the laptop)

countrywise
Broadband 3G
Posts: 828
Registered: ‎04-14-2012
Location: İstanbul
Views: 36,511
Message 7 of 52

Re: z580 can't access bios setup or boot menu after changing to Legacy from UEFI mode

Try holding down the B key at boot,

 

İt may open the Windows boot menu.

 

 

 

 

OKR-MAN
WWAN
Posts: 382
Registered: ‎06-08-2012
Location: Ankara , Turkey
Views: 36,465
Message 8 of 52

Re: z580 can't access bios setup or boot menu after changing to Legacy from UEFI mode

Hello , 

 

Please kindly press fn+f2 at the same to enter bios. If it doesnt work you need flash the bios with same bios version to set the bios to default. In this case please contact with local customer care looks like there is no bios update on the support site.  Let us know the result.

 

Thanks 

radicalg
Paper Tape
Posts: 7
Registered: ‎07-29-2012
Views: 36,445
Message 9 of 52

Re: z580 can't access bios setup or boot menu after changing to Legacy from UEFI mode

I will definitely try the fn+f2 method, although holding B didn't work.
However, i have a feeling i'll eventually have to take it back to flash the BIOS.. in that case, what will change about my laptop? I mean will i lose any data or settings?

pletiks
Paper Tape
Posts: 2
Registered: ‎09-07-2012
Location: Poland
Views: 36,174
Message 10 of 52

Re: z580 can't access bios setup or boot menu after changing to Legacy from UEFI mode

Hi,

I have exactly the same problem ans sadly fn+f2 doesnt work. Guys from tech support olso have no idea, and there is no bios avaible to reinstall Smiley Very Happy good job Lenovo.

Check out current deals!


Shop current deals

Top Kudoed Authors