cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
BigDHouston
Paper Tape
Posts: 1
Registered: ‎10-30-2017
Location: US
Views: 321
Message 1 of 1

IdeaPad U430 doesn't turn on

A friend asked me to look at his U430 Touch because it wouldn't come on. I have tested the power supply at 20.4v to both the center pin and the shell. The battery shows 7.18 v between black and red. I have disconnected the battery and the power supply, done the tricks to discharge the capacitors and bleed off any residual voltage. Those did nothing. I then removed all power including the CMOS battery and tried again. Still nothing. I tried connecting the power supply with the battery out. Still nothing. The only indication of life is that the Charging Light comes on when the battery is connected and the power supply is on. No bump of the fan, no flash of any light, nothing. Oh, if I hold the power button on for 20 seconds with all power sources connected, the Charging Light will go out for 4 seconds, so I know that the power switch is functional.

 

I would appreciate any words of wisdom. I hate to think it is the motherboard.

 

Thanks,

Dennis

Check out current deals!


Shop current deals

Top Kudoed Authors