English Community

Lenovo NotebooksLenovo U and S Series Notebooks
All Forum Topics
Options

1 Posts

07-15-2017

US

1 Signins

26 Page Views

  • Posts: 1
  • Registered: ‎07-15-2017
  • Location: US
  • Views: 26
  • Message 1 of 2

IdeaPad s210 touch - touchscreen driver not found?

2017-07-15, 21:36 PM

A couple weeks ago, my touchscreen and usb drivers suddenly disappeared when the laptop did an automatic update and the battery drained over night. I fixed it briefly by going into the advanced start up and restoring my computer to a point before it had stopped working. Well, battery drained over night again and drivers vanished. As did the restore point I had used. I have fixed the usb issue, but I cannot for the life of me get this stupid screen to work. In the device manager, it's listed under "other devices" with a yellow warning. Click it and it brings up Code 28. I have been to the update drivers section on Lenovo. Updated things that I have read on here worked for others, nothing. I have uninstalled, restarted my laptop, driver still won't install. I have run diagnostics and they came up with nothing. Researching into the far reaches of the internet is making my head hurt and not yielding much that's relevant to my model. I have had this laptop for years with no issues (except a few slight manageable ones). It's out of warranty, I can't afford a new one, and depending on how much it could cost me, having someone repair it for me. 

 

Can anyone provide some direction to help me fix this? It isn't hugely pressing now that I have a working mouse, just more of a major annoyance when I habitually poke and swipe the screen. I'm fairly tech savvy, but I've reached my "I want to chuck it over a cliff" limit.

 

Any help and advice is greatly appreciated! Thank you!!

Reply
Options

2953 Posts

02-22-2017

GB

1083 Signins

26243 Page Views

  • Posts: 2953
  • Registered: ‎02-22-2017
  • Location: GB
  • Views: 26243
  • Message 2 of 2

Re: IdeaPad s210 touch - touchscreen driver not found?

2017-07-17, 14:41 PM

Hello MiraMira777

Thanks for using the Lenovo forums.


Try to download the Video and Chipset drivers for the unit from the support page.

 

Make sure to reboot after an update on the unit.

If that doesn't work, and you've done a reset, I would recommend to attempt a factory reset next, this should confirm if the issue is with the hardware or not.

 

Hope this helps, let us know how you get on.


==================================================================================
Did someone help you today? Thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!

 

This will help the rest of the Community with similar issues identify the verified solution and benefit from it.



Pesszimistának lenni a legjobb, vagy igazad van, vagy kellemesen meglepődsz...
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save