cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
guferr
Fanfold Paper
Posts: 4
Registered: ‎01-06-2020
Location: BR
Views: 394
Message 1 of 2

Ideapad S145-15IWL restarting few seconds after entering the BIOS menu (and other simple systems)

My Ideapad is restarting about 12 seconds after being powered on (or after rebooting), unless if a complete OS (like Linux or Windows) boots and takes control.

If I enter the BIOS menu, it will reboot 12 seconds after entering, disregard of anything I do.

The same happens if I enter the boot menu (through F12) and leave it open, 12 seconds after it reboots.

Same thing also happens if I enter a boot loader menu, a DOS or any other software that isn't a more complete OS.

For example, Memtest86+ (which is a bootable stand-alone) also reboots after a few seconds, even though it's a long mode (64-bit) software.

Memtest86+ doesn't detect problems nor reboot in the same part of the test either, the time it takes to reboot depends on how much time I took since power on until I load it (If I wait 9 seconds until selecting it in the bootloader, it will have only 3 seconds left to run).

Other people seemingly had similar problem with this same model (in the brazillian community),  and trying to update the BIOS got it corrupted, because the UEFI capsule update also reboots a few seconds into the process and leave an unusable computer.

The problems other people have didn't begin in the same way (they usually began after an update and mine was never updated), and their solutions don't fit me either, they usually involve updating the BIOS (which I'm not going to risk) or updating UEFI drivers (which I don't even have, I only use legacy boot and there are no UEFI partitions in my hard drive).

My computer wasn't behaving like that just a few days ago and It barely has a month of use. What could be happening?

Thanks!

Ps.: I have already tried cleaning the CMOS memory. I disconnected the battery and the CMOS battery, letting it off for 5 minutes and put all back again: No change. It did clear the CMOS memory but didn't improve it's behavior.

I also tried powering it on without the battery and the hard drive: No change either, still the same behavior.

guferr
Fanfold Paper
Posts: 4
Registered: ‎01-06-2020
Location: BR
Views: 359
Message 2 of 2

Re: Ideapad S145-15IWL restarting few seconds after entering the BIOS menu (and other simple systems

I found a way around the problem.

It seems that even thought removing the CMOS and the main battery did reset the clock, it didn't actually clear the CMOS memory.

And although I was pretty sure that I've tried that before, I loaded the default BIOS settings and that fixed the problem.

Then I tested each item and found the culprit: Disabling the PXE boot option triggers this. Leaving it enabled avoids it. No other option seems to interfer.

Maybe someday I disabled the option because I don't use it and after that I never lasted long enough in the BIOS menu to perceive the problem I caused, until I had to today.

This is certainly a BIOS bug, no feature would do that purposefully. It seems that some kind of "timer" is being set to reboot the computer, and this "timer" is either hardware-mediated or part of a BIOS routine, that keeps running even after some simple system (like DOS or Memtest86+) takes control. Those simpler systems will usually not deal with most of the hardware features and won't mess with the BIOS routines either.

Only when a more complete OS, with drivers to take control of all of the hardware loads they stop this "timer" or whatever is the routine making this behavior.

And we're back...

Move delayed but still coming

Learn More

Check out current deals!


Shop current deals

Top Kudoed Authors