Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
Community Spotlight

Visit the Lenovo Blogs!

Check out the ThinkPad Time Machine
Visit the Community Spotlight Blog
Windows  10

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
Reply
What's DOS?
Posts: 1
Registered: ‎06-18-2012
Location: Singapore
0 Kudos

Not able to start s10-3 Lenevo Laptop

I tried upgrading my RAM, and inserted the spare DDR3 2 GB ram into the memory slot of Lenevo S10-3 laptop, but unfortunaly after doing this my laptop is not booting up at all. I tried re-inserting the old memory but still the laptop is not starting up. Only the middle two led's glow i.e. the battery (charging) and wireless (second from right).

 

Can somebody guide me as what to do to make my laptop start again.

I took the laptop to the lenevo suppport who said that since my warranty has expired long ago, it will cost me more than $500 and also labour charges and tax extra, the cost of my laptop is $349, hence looking for some expert comments here.

 

Thanks a lot in advance.

 

Regards,

Sachin

Highlighted
Posts: 2,363
Registered: ‎01-21-2009
Location: Germany Hannover
0 Kudos

Re: Not able to start s10-3 Lenevo Laptop

Hi and welcome,

" tried re-inserting the old memory "

check or  re-seat of the former memory carefully again ...

be sure that you remove the battery and powerplug ... press start switch for 30 seconds .. plug in powerplug and try to start...

 

regards KK

 

 

______________________________________
Thinkies 2x X200s/X301 8GB 256GB SSD @ Win 7 64
Ideas Centre A520 ,Yoga 2 256GB SSD,Yoga 2 tablet @ Win 8.1