cancel
Showing results for 
Search instead for 
Did you mean: 
Lenovo Staff
Views: 10,307

Question

If you have s10-3, s10-3c, s10-3s, s10-3t, you may not be able to upgrade to 2GB RAM whereby you may see only a black screen while trying to boot up the machine after the upgrade. 

Answer

 If these symptoms occur, check for the latest BIOS available and perform the flash update.

Please ensure that you perform a cold boot before applying the BIOS update and ensure that you download and apply the correct file based on the model of system you have. 

 

    s10-3 bios v37 (2ACN37WW.exe)
    Change history:
    Fixed the memory compatibility issue
    s10-3c bios v13 (3CCN13WW.exe)
    s10-3t bios v62 (24CN62WW-win.exe)
     s10-3s BIOS 30  (LM30_0224.exe)

 

Important: Reboot your machine prior to bios update

 

BIOS and other driver downloads can be obtained from the End of Life Product Resource

 

Note: Please press F2 to access bios, then press F9 and load default settings in order to get machine works properly after new bios update.  Lenovo cannot guarantee compatibilty with all memory manufacturers and modules.

Was this information helpful?

Comments
mm-CZ

Hi all,

 

I've re-installed W7 and tried to extend my RAM. I was unable to boot so I've booted into W7 (without any additional SW installed) with original RAM module and started updating the BIOS of my Ideapad S10-3. BIOS version and compatibility was verified, backup successfully created and then update started. It passed through all 15steps and then S10-3 shutted down and won't boot. Tried removing battery for 10minutes, changed RAM modules however all without any success. I have just blank black screen now. What should I do now?

 

Thank you for any help.