English Community

Lenovo NotebooksLenovo U and S Series Notebooks
All Forum Topics
Options

3 Posts

07-05-2019

US

3 Signins

31 Page Views

  • Posts: 3
  • Registered: ‎07-05-2019
  • Location: US
  • Views: 31
  • Message 1 of 9

S340-15IWL touch HDMI doesn't work with ACHI mod

2019-07-05, 18:32 PM

Hi,

 

The HDMI output of my new S340-15IWL touch works with the stock windows 10 Home installed on the stock 256GB M.2 NVMe SSD drive with BIOS disk control configured as RST mode. However, after installing a second SATA SSD with a windows 10 EDU OS, and changing BOIS disk control to ACHI mode to allow boot from the SATA SSD, the HDMI outpot stoped working anymore. I have updated the video driver to the lastest one posted on lenovo support website. but the HDMI still doesn't work.

 

It looks like this HDMI problem comes after changing BIOS disk controller to ACHI mode. not sure it is due to the BIOS or the video driver. Can someone give some support? I have to get a seocnd output working for being able to project presentations.

 

THanks

 

 

 

 

 

Reply
Options

34 Posts

06-28-2019

US

55 Signins

424 Page Views

  • Posts: 34
  • Registered: ‎06-28-2019
  • Location: US
  • Views: 424
  • Message 2 of 9

Re: S340-15IWL touch HDMI doesn't work with ACHI mod

2019-07-12, 17:10 PM

Thanks for posting this issue.  I hope you/we hear back from someone on this issue.

Reply
Options

1 Posts

08-09-2019

BG

1 Signins

28 Page Views

  • Posts: 1
  • Registered: ‎08-09-2019
  • Location: BG
  • Views: 28
  • Message 3 of 9

Re: S340-15IWL touch HDMI doesn't work with ACHI mod

2019-08-09, 12:25 PM

I can confirm that in ACHI mode for storage HDMI not working at all.

Reply
Options

3 Posts

09-17-2019

RU

3 Signins

27 Page Views

  • Posts: 3
  • Registered: ‎09-17-2019
  • Location: RU
  • Views: 27
  • Message 4 of 9

Re: S340-15IWL touch HDMI doesn't work with ACHI mod

2019-09-18, 6:55 AM

I had the same issue and i hope Lenovo will see it and try to fix it faster, because i don't want to bring back this notebook it's so cool, and I think it will be very big + to company reputation if they react to this fast.

Reply
Options

3 Posts

10-03-2019

RO

2 Signins

22 Page Views

  • Posts: 3
  • Registered: ‎10-03-2019
  • Location: RO
  • Views: 22
  • Message 5 of 9

Re: S340-15IWL touch HDMI doesn't work with ACHI mod

2019-10-03, 12:56 PM

Hello,

Please try to change in BIOS the boot mode from Legacy to UEFI and try after this (pic attached) . 

 

I had this problem did clean install all windows updates , all drivers updates it did not work untill i changed from Legacy to UEFI .

 

Regards, 

Csaba

Reply
Options

3 Posts

07-05-2019

US

3 Signins

31 Page Views

  • Posts: 3
  • Registered: ‎07-05-2019
  • Location: US
  • Views: 31
  • Message 6 of 9

Re: S340-15IWL touch HDMI doesn't work with ACHI mod

2019-10-03, 15:29 PM

Under ACHI mod, only boot mode from Legacy is supported. 

Reply
Options

3 Posts

10-03-2019

RO

2 Signins

22 Page Views

  • Posts: 3
  • Registered: ‎10-03-2019
  • Location: RO
  • Views: 22
  • Message 7 of 9

Re: S340-15IWL touch HDMI doesn't work with ACHI mod

2019-10-04, 8:33 AM

Hello,

I installed windows with AHCI & Legacy - after i changed to UEFI  and it works .

 

attached print screen of both settings now , and HDMI works . 

 

Regards,

Csaba

Reply
Options

1 Posts

04-03-2020

UA

1 Signins

5 Page Views

  • Posts: 1
  • Registered: ‎04-03-2020
  • Location: UA
  • Views: 5
  • Message 8 of 9

Re: S340-15IWL touch HDMI doesn't work with ACHI mod

2020-04-03, 16:27 PM
BIG TNX for advice: I did the same (changed Legacy to UEFI) - by now it is working with monitor via HDMI
Reply
Options

1 Posts

04-04-2020

US

2 Signins

10 Page Views

  • Posts: 1
  • Registered: ‎04-04-2020
  • Location: US
  • Views: 10
  • Message 9 of 9

Re:S340-15IWL touch HDMI doesn't work with ACHI mod

2020-04-04, 1:44 AM

I am having this same issue with the IdeaPad S340-14IIL, I just bought this laptop less than a month ago for my college studies, and I find it really good until I tried to connect my pc to my tv, or any other external monitor using HDMI cable, it does not work, I even tried using a dongle using the USB-C port and connecting it to a HDMI and I had the a similar result, unable to use it, I check on the BIOS to see if I could change the legacy mode to UEFI and I realized it was already at UEFI, I don't know what to do, I found several people with the same issue but not answers on the internet, and on top of that my twin brother is having the same issue with the same laptop.

 

 

Thank you!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete