cancel
Showing results for 
Search instead for 
Did you mean: 
Lenovo Staff
Views: 6,546

Question

I have an S510p Touch model running Windows 8.1.

 

This morning my keyboard and mouse started acting erractically. The keyboard pops into Caps without the Capslock being put on and letters also go missing as I type. Instead of numbers popping up weird symbols appear on screen.

 

When selecting items on the desktop my mouse selects multiple items. The scroll wheel is also not working. This is also happening on a regular keyboard I plugged in. My mouse is a Logitech M 325.

 

I tried to roll back to a previous restore point and got a message:

 

SYSTEM RESTORE FAILED. THAT DRIVE MAY BE CORRUPT AND AN UNSPECIFIED ERROR OCCURRED DURING SYSTEM RESTORE.

 

It was recommended that I run chckdsk. I did so and no errors were detected.

 

Answer

First, try clearing the CMOS to see if that resolves the issue.  The clearing of CMOS can be useful in resolving some hardware conflicts.  Just follow the steps below:


1. Unplug the charger / adapter.
2. Remove the battery.
3. Press and hold the Power Button for 15 seconds.
4. Re-install the battery, plug in the charger / adapter if needed and power up the system to see if the problem was resolved.

 

If the clearing didn't work then next uninstall the mouse / keyboard driver, reboot the computer and then install a fresh copy.  The link below is for a download of the available driver....

 

http://support.lenovo.com/us/en/products/laptops-and-netbooks/ideapad-s-series-netbooks/ideapad-s510...

 

If the driver install didn't work then it is recommended that you call Lenovo Support for additional service as the problem may likely be hardware related.

 

Was this information helpful?

Comments
AnnaInMD

I have an ideapad S510p which was automatically updated to Win 10. Since then, the touch no longer works. Please advise.  Much appreciated.

Vargaras

I have a Ideapad 100-15IBD and the mouse sometimes starts acting erratically for no apparent reason, the display may start zooming, sometimes the Internet window I am browsing is shut-off, or the mouse acts as if someone was controlling it and opens and closes windows without control. I cannot control it, I have tried unplugging the mouse remote at the USB and using the touchpad, but it doesn't work when this is hhappening. I have to shut off the compu, wait a while, and when I start it it's fine. Itis extremely frustrating. If I am writing an email I usually loose all I've typed.

estunner

Hi , I am facing some kind of the same issue here. The mouse is not working at all. I did tried to unplug the battery but still the issue of no-mouse continues. Any alternative ways?