cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Swigert
Paper Tape
Posts: 7
Registered: ‎08-21-2010
Location: Germany
Views: 4,086
Message 1 of 59

U160 Turbo Boost broken?!

Hi,

 

I currently own a brand new i7-620UM based U160, and it gives me some headaches about performance.

 

After wondering why I've never come any close to the 2.13 GHz maximum clock rate of the cpu, I have found evidence that there's more people than just me suffering from this. There's at least some tests between U160 with i5-520UM and the equal model from Acer (1830T). The latter beats the U160 by at least one order of magnitude when it comes to cpu performance (especially the Windows 7 performance index).

 

To me it seems that Lenovo has somehome screwed up with Turbo Boost at least on the U160 with i5-520UM and the i7-620UM. I have recently opened a case with Lenovo, but no response so far (no offense, it's only been open for a day or two).

 

I wonder if anyone here's been making similar experience. What have your steps been so far to remedy this?

 

Best regards,

 

 Steffen

 

 

Retired Moderator
Retired Moderator
Posts: 13,719
Registered: ‎12-07-2009
Location: CZ
Views: 4,031
Message 2 of 59

Re: U160 Turbo Boost broken?!

Swigert
Paper Tape
Posts: 7
Registered: ‎08-21-2010
Location: Germany
Views: 4,020
Message 3 of 59

Re: U160 Turbo Boost broken?!

Hi Yigit,

 

first, thank you for the information.

 

The U160 bios does not come with a switch to turn Turbo Boost on or off. So it's always turned on.

 

I've been able to see with Intel's TB monitor gadget that Turbo Boost is indeed working, but the clock speed it reaches at max is totally unsatisfying. So far I have not found a way to bring the cpu to more than about 1.6 GHz, whereas that chip's spec says it will reach 2.13 GHz. Running at a maximum of only 75% of this cpu's specified capabilities is not an option for me. That's not what I've chosen this cpu for (no offense).

 

Best regards,

 

 Steffen

Retired Moderator
Retired Moderator
Posts: 13,719
Registered: ‎12-07-2009
Location: CZ
Views: 3,982
Message 4 of 59

Re: U160 Turbo Boost broken?!

you're right. if you chose turbo model, it's normal behavior that you expect to use all of the performance.

i haven't found a chance to test turbo boost, so, that's all i can suggest for now.

hope someone else can help you.

or you can call lenovo.


http://www.krasotaiskusstva.com
coles
Paper Tape
Posts: 1
Registered: ‎08-25-2010
Location: Toronto
Views: 3,897
Message 5 of 59

Re: U160 Turbo Boost broken?!

The U160 performance issues were also mentioned in Notebookcheck's review.

 

Steffan: when you get a response from Lenovo, please do us all a favor and post it here.

 

Has anyone out there been able to get their U160 to the full turbo clock speed?

callsignapollo
Blue Screen Again
Posts: 26
Registered: ‎06-28-2010
Location: Sydney AU
Views: 3,884
Message 6 of 59

Re: U160 Turbo Boost broken?!

The U160 has been removed from Lenovo's website (US).

 

I've not tested my clock speeds but I have had issues with USB devices when resuming from sleep.

 

Perhaps there are some issues with the U160? That being said, I'm very happy with mine apart from the above thread.

callsignapollo
Blue Screen Again
Posts: 26
Registered: ‎06-28-2010
Location: Sydney AU
Views: 3,820
Message 7 of 59

Re: U160 Turbo Boost broken?!

I just checked my turbo boost. I agree it seems broken. I fired up MW2 and CSS to see how they would run on the integrated graphics and the CPU didn't go above 1550mhz per core.

krabbelmonster
Paper Tape
Posts: 5
Registered: ‎09-01-2010
Location: germany
Views: 3,719
Message 8 of 59

Re: U160 Turbo Boost broken?!

Hi I am an owner of a U160 with core i7. The broken Turbo Boost happens to me, too.

 

Last time I tried some things with Win 7 (for normal I use Linux) I take a closer look with CPU Z 1.55. It looks like an invertet Turbo Boost! When the U160 looks IDLE the CPU freq is increasing up to 2.1 GHz and when I start a benchmark or stress test, the system speed goes down to minimum freq.

 

I there someone who can try it, too?

 

cu

Sascha

Former Administrator
Posts: 8,592
Registered: ‎11-19-2007
Location: US
Views: 3,669
Message 9 of 59

Re: U160 Turbo Boost broken?!

All,

 

Thanks for noting this.  A limited number of U160 systems shipped with a configuration error at the system board level that affects the proper function of the turbo boost function.   Lenovo has notfied resellers and is working to ensure that affected inventory is taken care of.

 

We are finalizing our plan to aid customers who have an affected system and I expect to be able to update you on this by end of Thursday this week.

 

Best regards,

 

Mark

callsignapollo
Blue Screen Again
Posts: 26
Registered: ‎06-28-2010
Location: Sydney AU
Views: 3,652
Message 10 of 59

Re: U160 Turbo Boost broken?!

Hi Mark,

 

Appreciate the update, and the honesty. Just a personal note - if there will be a BIOS/firmware solution for this at some point it would be great if we have access to do that ourselves. For some of us, it's not so easy to return our laptops for service.

 

Thank you,


callsignapollo

Check out current deals!


Shop current deals

Top Kudoed Authors