Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Lenovo NotebooksLenovo U and S Series Notebooks
All Forum Topics
Options

41 Posts

02-15-2009

Japan

64 Signins

716 Page Views

  • Posts: 41
  • Registered: ‎02-15-2009
  • Location: Japan
  • Views: 716
  • Message 51 of 123

Re: Fan Control for the S10(e) - user-developed solution

2009-05-25, 13:37 PM

Loser: I have a few questions:

 

1. Are you using the most recent build. 2009.05.24? Be sure you are using the most recent one.

2. What version is your Lenovo Energy Management?

3. Which Power Schemes are you using?

 

BTW, my Lenovo Energy Management is version 3.0.1.6 and I normally use balance or super energy saving Power Schemes. I am using BIOS 90 on my S10.

 

 

Carsten: Could you remove the links to my older builds from the top page, please? Thanks.

 

-Slash

Message Edited by slash on 05-25-2009 06:48 AM
Reply
Options

53 Posts

03-24-2009

Norway

423 Signins

1445 Page Views

  • Posts: 53
  • Registered: ‎03-24-2009
  • Location: Norway
  • Views: 1445
  • Message 52 of 123

Re: Fan Control for the S10(e) - user-developed solution

2009-05-25, 16:00 PM

1. Yes, I tried the latest build.

2. Not sure what build the power manager is, but it's the latest. I don't use it though. I only use Windows 7's build-in management.

3. Using the balanced scheme in W7.

Reply
Options

41 Posts

02-15-2009

Japan

64 Signins

716 Page Views

  • Posts: 41
  • Registered: ‎02-15-2009
  • Location: Japan
  • Views: 716
  • Message 53 of 123

Re: Fan Control for the S10(e) - user-developed solution

2009-05-25, 16:48 PM

Loser: I've only had time to test the program with windows xp. I do know that the standard windows ACPI driver has changed much from VISTA and up. I presume there is something different with windows7 as well. Anyway, thanks for the feedback.

 

-Slash

Reply
Options

4 Posts

02-25-2009

Europe

15 Signins

70 Page Views

  • Posts: 4
  • Registered: ‎02-25-2009
  • Location: Europe
  • Views: 70
  • Message 54 of 123

Re: Fan Control for the S10(e) - user-developed solution

2009-05-25, 17:53 PM

Slash:

 

You have a great program, but it doesn't work on my system either. I'm on WinXP, S10, BIOS 51,Energy Management 3.0, on Super Saver. When the program is checking for the thresholds, it doesn't affect the fan in any way. Would be great if you could help, as I'm pretty reluctant to flash new BIOS.

Reply
Options

56 Posts

04-11-2009

Germany

131 Signins

1474 Page Views

  • Posts: 56
  • Registered: ‎04-11-2009
  • Location: Germany
  • Views: 1474
  • Message 55 of 123

Re: Fan Control for the S10(e) - user-developed solution

2009-05-25, 18:04 PM

The program will not work on BIOSes before 58 because the offset has changed.

 

BIOS >= 58: offset 0x50, real temperature + 20°C 

BIOS <= 57: offset 0x51, real temperature

 

(as far as i know)

 

 

Greetings

 

Carsten

Message Edited by Carsten on 05-25-2009 08:05 PM
Reply
Options

2420 Posts

01-21-2009

Germany

2771 Signins

119910 Page Views

  • Posts: 2420
  • Registered: ‎01-21-2009
  • Location: Germany
  • Views: 119910
  • Message 56 of 123

Re: Fan Control for the S10(e) - user-developed solution

2009-05-25, 23:28 PM

Slash, today i tried the S10Fan today... works well ..

My Config... is the preference that you have...set as default...

S10e 4WG with S10 90 BIOS  EM 3.0.2.1 set to Balanced profile ...

Used your SETUP ....

and confirm all Level temp are the right ones 60,65,70,80 ...

so i applied 70,75,80,85

used coretemp 0.99.5 b20 to check the temps ,

yes it show exactly -20 C to low...the normal difference, thats also correct..

 

Starting 2 x Prime to Stress the cpu... and the only Level ive heard after a long time was Level 1..

start at temp 50C (+ 20 C diff = 70C).

so all is working very well...  

 

Great job...

sincerely Kalvinklein

Yoga Home 900 - Yoga 2 11- Yoga tablet 2 all WIN 10 1809
Moto Z Play - Moto Z2 Play
Reply
Options

56 Posts

04-11-2009

Germany

131 Signins

1474 Page Views

  • Posts: 56
  • Registered: ‎04-11-2009
  • Location: Germany
  • Views: 1474
  • Message 57 of 123

Re: Fan Control for the S10(e) - user-developed solution

2009-05-26, 8:42 AM

Hi.

 

@slash:

I've tested S10Fan on my S10e 40684JG with BIOS 66: battery detection failed after about 2 minutes.

- Windows XP Professional SP3

- Lenovo Energy Management 3.0.2.1

- Balanced

 

@all:

My automatic NHC-setup is working so far. For now the test version (only in German):  http://forum.eeepcnews.de/download/file.php?id=1466, please use the guide: http://forum.eeepcnews.de/viewtopic.php?f=70&t=7190&start=25#p64144

 

 

Greetings

 

Carsten

Message Edited by Carsten on 05-26-2009 10:53 AM
Reply
Options

5 Posts

04-21-2009

Germany

27 Signins

110 Page Views

  • Posts: 5
  • Registered: ‎04-21-2009
  • Location: Germany
  • Views: 110
  • Message 58 of 123

Re: Fan Control for the S10(e) - user-developed solution

2009-05-26, 10:41 AM

@KalvinKlein regarding post 47

 

Hi,

 

I posted a solution for the event viewer issue, which works great for me here:

http://forums.lenovo.com/lnv/board/message?board.id=IdeaPad_Netbook&thread.id=795&view=by_date_ascending&page=83

 

(post 822 :smileyhappy: )

 

Greetings

Reply
Options

41 Posts

02-15-2009

Japan

64 Signins

716 Page Views

  • Posts: 41
  • Registered: ‎02-15-2009
  • Location: Japan
  • Views: 716
  • Message 59 of 123

Re: Fan Control for the S10(e) - user-developed solution

2009-05-26, 14:26 PM

Guys, thanks for the feedbacks. It looks like the EC command sequence isn't related to the battery issue afterall. I dare say bios version with only two cases but anyone else with S10e bios 66 have the same issue? In any case, it's rather pointless to persue over writing the EC registers like I do if there are cases like this. Oh well, I guess it's back to the drawing board.

 

-Slash

Reply
Options

5 Posts

04-21-2009

Germany

27 Signins

110 Page Views

  • Posts: 5
  • Registered: ‎04-21-2009
  • Location: Germany
  • Views: 110
  • Message 60 of 123

Re: Fan Control for the S10(e) - user-developed solution

2009-05-26, 16:06 PM
@slash 

First, thank you very much for the nice program.

 

I do have s10e (4068-4KG) with bios 66. I have been running your program for near 5 hours now, and I don't have the battery issue. The icon is still there,

although I had the problem with the program from dresslerc. I was also playing with the icon :smileyhappy: by plugging the AC Adapter in and out several times during those 5 hours, making it to appear and disappear, but at the end it was still error free.

 

One tiny problem I am experiencing on my configuration is, that occasionally the fan kicks in at 50-51 C - reported by Core Temp 0.99.5 (+20 meaning 70-71 C),

although I have set 75 C as custom value for level 1 - should come first at 55 C.

My bios levels are 58,60,67,80, but I tested it with 60,65,70,75 (which were determined by the setup) and it's the same.

The Version of my Lenovo Energy Management Drivers is 3.0.2.1

 

Greeteings
Message Edited by palexof on 05-26-2009 06:08 PM
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms