cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
bthjf1
Paper Tape
Posts: 7
Registered: ‎03-26-2013
Location: England
Views: 3,825
Message 1 of 6

hard-drive not listed in BIOS after changing boot mode from Legacy to UEFI.

Due to the issue with Windows 7 being too dark on the Ideapad S400 (backlight issue), I decided to roll back to windows 8. To install Windows 7 from our deployment server I changed the BIOS to Legacy Support., but then to install Windows 8 I changed the BIOS back to UEFI but now under FI (Boot) only the network card is listed and not the hard-drive. If I roll back to BIOS to legacy then the hard-drive is listed as a boot device. Sound like a bug.

 

I really got the feeling that the BIOS of the Ideapad S400 is a beta. Will Lenovo issue a BIOS update in the near future? This is the worse laptop I've even seen so far! Smiley Mad

 

Social Support Agent
Social Support Agent
Posts: 5,822
Registered: ‎02-11-2012
Location: PH
Views: 3,811
Message 2 of 6

Re: hard-drive not listed in BIOS after changing boot mode from Legacy to UEFI.

hi bthjf1,

 

AFAIK, to see the HDD under UEFI boot on the BIOS, you must install Windows 8 in UEFI (HDD being formatted as GPT).

 

Try to:

1. Install Windows 8 in UEFI as stated in this guide.

2. Boot into the BIOS, press F9 to reset BIOS to default then check if HDD is now listed under EFI boot

 

 

Hope this helps



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebppl and Twitter!

bthjf1
Paper Tape
Posts: 7
Registered: ‎03-26-2013
Location: England
Views: 3,803
Message 3 of 6

Re: hard-drive not listed in BIOS after changing boot mode from Legacy to UEFI.

Well now I can't even go in the BIOS anymore to change back to UEFI to install Windows 8. (F2 or Fn + F2). I put back the BIOS back to Legacy so i could install the USB stick with Win8 . The laptop boot straight to Windows 7 which i can't use since this laptop is not compatible with Win7 (dark screen issue).

 

Any idea? Sorry loosing it ..

Social Support Agent
Social Support Agent
Posts: 5,822
Registered: ‎02-11-2012
Location: PH
Views: 3,795
Message 4 of 6

Re: hard-drive not listed in BIOS after changing boot mode from Legacy to UEFI.

hi bthjf1

 

Try to press the One Key Recovery button located at the left side of the unit then try and enter the BIOS Setup Utility.

 

 

Cheers



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebppl and Twitter!

bthjf1
Paper Tape
Posts: 7
Registered: ‎03-26-2013
Location: England
Views: 3,791
Message 5 of 6

Re: hard-drive not listed in BIOS after changing boot mode from Legacy to UEFI.

Success Smiley Very Happy Thank you very much !

bthjf1
Paper Tape
Posts: 7
Registered: ‎03-26-2013
Location: England
Views: 3,776
Message 6 of 6

Re: hard-drive not listed in BIOS after changing boot mode from Legacy to UEFI.

Guide was perfect. Thanks again.

Top Kudoed Authors