English Community

Lenovo NotebooksLenovo U and S Series Notebooks
All Forum Topics
Options

3 Posts

05-19-2016

LT

7 Signins

50 Page Views

  • Posts: 3
  • Registered: ‎05-19-2016
  • Location: LT
  • Views: 50
  • Message 1 of 2

u330p does not boot after disassembly

2019-04-05, 18:46 PM

So my friend spilled milk on the keyboard and after disassembly and cleaning, keyboard was still not working (W key was always engaged). After disconnecting old keyboard, connecting the external usb one and finding that it's really the keyboard that has a problem I decided to order new keyboard and disasembled the laptop again.

I tried to turn on the laptop just to do something with external keyboard but laptop just does not turn on. It lights up for 2 seconds, hdd clicks, no bios text or anything on the screen and then dies.

I then disassembled everything again, checked the cmos battery (voltage is 3.1V so its ok), cleaned the ram slot, dust and everything, assembled the laptop back - same result - 2 sec and dead.

Then I tried to weed out the bad component and saw that with another stick of ram laptop turns on for a longer ~15 second black screen, then shuts down and restarts again and does this in a loop (without anything on screen same as before, just some minimal backlight is visible.

 

I don't know what else can be done.

I don't have warranty anymore.

I don't think it's motherboard, since changing the ram changes the behavior of the laptop.

I tried connecting to external monitor via HDMI but no signal, same with internal screen disconnected.

I tried discharging the battery, and removing it (power from cable only).

I tried reseting the bios via removing the cmos battery and turning on the laptop.

 

Although it's possible that I had a static discharge on the laptop while I was disassembling it on a bed (can I destroy MB that way?)

 

Any thoughts or tips what could I do next? :(

Reply
Options

10852 Posts

01-02-2010

US

39506 Signins

411272 Page Views

  • Posts: 10852
  • Registered: ‎01-02-2010
  • Location: US
  • Views: 411272
  • Message 2 of 2

Re: u330p does not boot after disassembly

2019-04-09, 19:07 PM

That is the nature of liquid spills - symptoms often keep getting worse.  Milk contains sugars (lactose) and they corrode the electrical connections.  You need to try to get important data backed up and think about replacing the laptop


Rich


To help with forum searches, check this out: https:/forums.lenovo.com/t5/Welcome-FAQs/Using-Browser-Search-to-find-your-answers-in-Lenovo-and-Moto-Community/m-p/5016916

I do not respond to requests for private, one-on-one help. Your questions should be posted in the appropriate forum where they may help others as well.

If a response answers your question, please mark it as the accepted solution.

I am not an employee or agent of Lenovo.
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete