English Community

Lenovo NotebooksLenovo U and S Series Notebooks Knowledge Base

u350 wireless not working after upgrade from Vista to Windows 7


 I have a  U350 that came with Vista. First thing I did was clean install Win7 Home Premium and the network does not work, neither wired nor wireless.


So went to lenovo drivers download and isntalled

the Broadcom Ethernet Driver v12.2.4.2 dated 2009-10-21. This updated the two unknown devices noted in device manager for networks as these two:

- Broadcom NetLink (TM) Gigabit Ethernet

- Intel(R) WiFi Link 5100 AGN


So now the wired network is working but the wireless is still not. I have tried to make sure it is on doing the little slider on/off control and the Fn-F5 thing - but this does not do anything and the wireless light in the activity status lights by the touchpad does not turn on either.





Installing the Lenovo Energy Management utility is required for the Wireless to be turned on. As soon as I installed it the Fn-F5 keypress brought up the user interface to turn the wireless funciton on/off. Evidently the Fn-F5 is enabled by or targeted to that UI.


Ensure all the appropriate Lenovo drivers have been installed:


Drivers for wired ethernet


Drivers for wifi:

windows 7 32 bit :

windows 7 64 bit :  



Was this information helpful?

Yes No


Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop