Showing results for 
Search instead for 
Did you mean: 
Lenovo Staff
Views: 28,509


 The Lenovo Vantage Toolbar (Battery Gauge) may stop working.  There may also be an error message like "C:\ProgramData\Lenovo\ImController\Plugins\LenovoBatteryGaugePackage\x64\LenovoBatteryGaugePackage.dll The specified module could not be found."



 During a self-update, Lenovo System Interface Foundation was unable to successfully install the latest version of the Toolbar.



1.  Save the following file to your PC:

2.  From the folder where you saved the file, right-click on and choose "Extract All..."

3.  From the folder where you extracted, right-click on Fix-Battery-Gauge.bat and select the option "Run as administrator".  If you see a message like "Windows protected your PC", click on "More info" and then click on "Run anyway".

4.  If you see a message like "Do you want to allow this app to make changes to your device?", click on "Yes".

5.  Wait for the process to finish, and then press any key to continue, as prompted

6.  Right-click on some blank space in the task bar, then open the "Toolbars" menu, and click on Lenovo Vantage Toolbar to enable it.

Was this information helpful?


Hi guys, try this one. it brings back the battery gauge. I'll keep you posted once it was posted. just follow the instruction above. hopefully it works. once I restarted my PC.


Didn't work for me; I can reinstall the toolbar all right, but when I restart o switch off the computer it disappears again. Well actually it's still there for a few seconds after starting Windows and the disappears and the error message is displayed


In your case, it sounds like something keeps deleting the file.  What antivirus software are you using?  Can you check whether it is blocking or quarantining a file?  


Thanks for the reply, I've no antivirus software other than the windows default protection, and no notifications of blocking/quaratining have been displayed



I'm not sure what is happening in your case and I haven't heard this reported anywhere else.  I have another fix package that might help for your case, and it will create a log file so we can hopefully figure out what is going on.  Please download and extract this zip:!ApXWjQB7_a1bhftrlWTHULy50mR18A


Then double-click on FixBatteryGauge and wait for it to complete.  It may take a minute or more, when it's finished you'll see a message pop up like "Successfully!".  After it finishes, please send me that will be created in the same folder as FixBatteryGauge.  You can either upload it to onedrive/dropbox/etc and share a link here, or else e-mail it to me at


Thanks very much!


Worked flawless in a Lenovo Ideapad 110, with Windows 10 x64 version 1803 (updated). I was getting the error message since three days ago.


Thank you for the solution, It worked well for my system.


I can download the zipped file and upzip it, I can see all the files, but no where do I find one with the extension named "Fix-Battery-Gauge.bat"  I even searched for it in the search box...nothing. I still have the RUNDLL  box show up every time I boot up. I do have a battery indicator box in lower right tool bar. So I don't get what this dialog box is all about.



After you download the file and extracted all the files, it will create a folder named Fix-Battery-Gauge. Inside of that folder will be two files, Fix-Battery-Gauge.bat and

You don´t need to unzip the .cab file, just follow step 3 in the guide.

lenovillos, we checked your log.  We think we have fixed your problem in the next version.  But we also think if you just try running it again, it should work.  Can you please try it and let me know?


@someotherguy, problem magically solved. May I ask how?


I have a question: When I right click on the task bar to open "Toolbars" there's just: "Address, Desktop, Links, or new toolbar" as my only options — there is no Lenovo Vantage Toolbar to enable. How do I bring up this Lenovo Vantage Toolbar once I've right clicked and see the Toolbars at the top of the scrolldown?


Well, this is a reason why I've retracted my original statement of reccommending a Lenovo to any future PC buyer: the lack of reponse from admins to a problem!! Just to put that into perspective, you've already lost a couple of sales to Hewlett-Packard, who at least seem to be on top of things.


For the record, the problem eventually sorted itself out after a good 12 or more reboots. I never did enable the Fix file properly the way that was suggested in the first post, but hey ho.


Also, another thing that riles me up is your BIO updates. I do a scan for an update, it tells me I need a new one. I go to download, then I get a pop-up telling me: "This is for Ideadpa Touch" and do I want to continue?" If I decide to continue it then tells me I already have it installed!! What's going on? Look guys, can't your technicians at least seperate "touch" from "non-touch" when doing your updates? Also, if I have it already installed, then why does it prompt me to download it in the first place? What's going on over there? Is Lenovo being run by a skeleton staff of undergraduates, with the majority handing in their notices and heading for Hewlett-Packard or Apple instead?


in normal cases your solution can help. It did not work for me, because the installation of the System Interface Foundation failed all the time and so none of the files to be fixed could be found.

Setup of the System Interface Foundation  unpacked the files into the C:\users\<user>\AppData\Local\temp\is_KT8G5.tmp folder and finished without installing but removing the temp folder after clicking the "Close" button.


The file "ServiceTotal_Inst.cmd" in the temp folder helped me to find the reason, why all attempts of installation and fixes failed:

The cmd-file is using DOS commands, expecting the them in C:\Windows\system32 by the environment-variable "PATH".

I extraced the "find /i ..." command from the cmd file and typed it in the cmd console but it failed with a file not found ("/i" in cygwin represents a file named "i" in the root folder, but in the DOS-command "find" the "/i" is a command option).


I checked the PATH variable and found out, that on my computer the content of %PATH% started with:



So some DOS commands in Lenovo's installation files of System Interface Foundation and battery-gauge-fix tried to use the same commands from cygwin instead of Windows and failed due to syntax error.


After removing the Cygwin-paths from "PATH" variable installation of System Interface Foundation was successful and the battery gauge was back.


I recommend, to use external DOS-comands in setup packages with "%WINDIR%\System32\" as "command-prefix". 


Kind Regards



@Mornsgrans thank you very much for pointing this out!  I was able to reproduce the same problem after creating my own folder with a find.exe that isn't OS version, and then adding my folder to the system path.  Then, SystemInterfaceFoundation.exe appears to install successfully, but actually none of the required components end up getting installed.  I will pass along this information to the System Interface Foundation developers.  Again, thank you.


hello ..

I have the same probleme and i have tried the above 2 option and the same probleme .. 

and this is the link for BGT ..

help pls ..

Please first check the content of the folder


It should contaim approx. 40 files and folders.


In normal cases the folder C:\ProgramData is hidden bt if you type in the path in Windows Explorers address field, you can see its content.


As second step please check the content of the environment variable "PATH"

Start (windows flag) - Windows system - Command Prompt

Type in "path" (without quotation marks) and hit <enter>

As result you will get shown a long list, where one of the first entries should be "C:\windows\system32"



Microsoft Windows [Version 10.0.17763.253]
(c) 2018 Microsoft Corporation. Alle Rechte vorbehalten.





Please move the last two postings into separate thread outside the knowlege base.




hello ,, 


It contains 44  folders.


and I've tried the method above and no thing was done ! 

 could you help by another method ?


Ok, System Interface Foundation seems to be installed.


My next recommendation is:

- Activate the Account "Administrator" (Controlpanel - Administrative tools - Computer administration - Users and groups - Users right-click on "Administrator" - Properties)

- Login as .\administrator (including ".\")

- Try to enable Battery Gauge.

If this works, there is a permission problem and this posting might help.


Do not forget to disable the Administrator account again after the test.


thanks for fast response

I tried this method and the same problem no thing was appear ..

Could you try any desk or team viewer to see the problem pls

Thanks in advanced


Hey, It's work only for one time, I mean after teset the pc it disapear and i need to start this file again.

Can someone help me?