English Community

Software and Operating SystemLenovo Vantage Knowledge Base

"Vantage has Encountered a Problem" after Windows 10 updates to latest version (1809)

Symptoms

After updating to Windows 10 version 1809 or later, Vantage may display a message like Vantage has Encountered a Problem as shown below.

 

 

Diagnosis

This issue happens when Windows 10 fails to download and install the Device Metadata which is necessary for your PC to run normally.  To confirm the issue, open Control Panel -> Hardware and Sound -> Devices and Printers and check the icon that is shown for your PC under the Devices category.

 

The following icon shows a Windows 10 PC without any Device Metadata.  This is a problem.

 

 

 

The following icon shows a Windows 10 PC with old Windows 7 or Windows 8 Device Metadata.  This situation can happen if the PC was previously upgraded from Windows 7 or Windows 8.  This is also a problem.

 

 

 

If your PC shows one of the above icons, please follow the instructions in the Solution section of this document.

 

Solution

1.  Download this file: fix_metadata.zip

2.  From the folder where you downloaded it, right-click on fix_metadata (the compressed zip folder) and choose the option to Extract All.

3.  From the folder where you extracted the zip, right-click on fix_metadata (the Windows Batch File) and choose the option to Run as administrator.

4.  Press any key to continue, as prompted

5.  Go back to Control Panel -> Hardware and Sound -> Device and Printers.  If you see the red L icon as shown below, you are done.  If you don't see it, go to step 6.

 

 

6.  Sometimes it is necessary to click on the Refresh button as shown below:

 

 

When you see the red L icon, you should be able to run Vantage successfully.

Was this information helpful?

Yes No

Comments

GJ3 On 2019-01-25, 7:16 AM

Many thanks - this has resolved my issue 

esb41 On 2019-02-20, 15:54 PM

yes this resolved my issue. however if after you refresh you dont see the red icon just ensure all windows upates  are installed and restart you pc.

 

regards

freddellmeister On 2019-03-14, 18:35 PM

Strange I have the T530 icon on a P51 which shipped with Windows 10. The fix worked fine though!

Thanks

Ribosome On 2019-04-30, 10:40 AM

That worked.  The red icons never appeared.  But, after I rebooted, Vantage worked.

 

Thanks for the solution and the clear instructions.  Much appreciated.

mcwong On 2019-05-24, 12:37 PM

thanks, it works but still dunno why the metadata is missing and why it's required to fix/create it?

doloh On 2019-07-11, 8:59 AM

this solution doesnt work.my lappy is legit since it was legion y520-ikbn running 10 v1903! i think the problem is on lenovo's end (their app programming team). what a sloppy app that got me frustrated big time! this problem has not only affected the vantage but the Lenovo Settings app too. [see the attached image]

 
 
raedidp On 2019-07-11, 11:05 AM

My Lenovo Vantage is keep doing this. It's suddenly closed right after I open it. I've tried your solution above but it makes no change. It starts being like this (maybe) after I got updates on windows.

 

FYI I used Lenovo Legion Y740.

 

Please help me and thanks before!
Go to https://youtu.be/PojfACiI1U8

doloh On 2019-07-11, 11:40 AM

@raedidp

like i said earlier lenovo app's ecosystem itself is flawed and not future-proof. lenovo team should re-develop app from scratch to make it future-proof for us consumer. **bleep** is this all about if app keeps failing whenever a new build update release by microsoft took place on our pc.

doloh On 2019-07-12, 7:46 AM

well today just lucky day for me in the middle of nowhere out of a blue a windows update prompt me to update the machine so i keep it updated hoping for a miracle in mind once finished i run those apps to see and it finally work again and im good being as okay and relax by now but im still hating lenovo and i strongly believe theres something not right with the ecosystem of their apps since ive never experienced that with other oem vendors their app is flawless to be truthful here and they never screwed me like lenovo did!

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Delete