cancel
Showing results for 
Search instead for 
Did you mean: 
Lenovo Staff
Views: 8,618

Symptoms

After updating to Windows 10 version 1809 or later, Vantage may display a message like Vantage has Encountered a Problem as shown below.

1.png

 

 

Diagnosis

This issue happens when Windows 10 fails to download and install the Device Metadata which is necessary for your PC to run normally.  To confirm the issue, open Control Panel -> Hardware and Sound -> Devices and Printers and check the icon that is shown for your PC under the Devices category.

 

The following icon shows a Windows 10 PC without any Device Metadata.  This is a problem.

 

2a.png

 

 

The following icon shows a Windows 10 PC with old Windows 7 or Windows 8 Device Metadata.  This situation can happen if the PC was previously upgraded from Windows 7 or Windows 8.  This is also a problem.

 

2b.png

 

 

If your PC shows one of the above icons, please follow the instructions in the Solution section of this document.

 

Solution

1.  Download this file: fix_metadata.zip

2.  From the folder where you downloaded it, right-click on fix_metadata (the compressed zip folder) and choose the option to Extract All.

3.  From the folder where you extracted the zip, right-click on fix_metadata (the Windows Batch File) and choose the option to Run as administrator.

4.  Press any key to continue, as prompted

5.  Go back to Control Panel -> Hardware and Sound -> Device and Printers.  If you see the red L icon as shown below, you are done.  If you don't see it, go to step 6.

 

3.png

 

6.  Sometimes it is necessary to click on the Refresh button as shown below:

 

3.png

 

When you see the red L icon, you should be able to run Vantage successfully.

Was this information helpful?

Comments
GJ3

Many thanks - this has resolved my issue 

esb41

yes this resolved my issue. however if after you refresh you dont see the red icon just ensure all windows upates  are installed and restart you pc.

 

regards

freddellmeister

Strange I have the T530 icon on a P51 which shipped with Windows 10. The fix worked fine though!

Thanks

Ribosome

That worked.  The red icons never appeared.  But, after I rebooted, Vantage worked.

 

Thanks for the solution and the clear instructions.  Much appreciated.

mcwong

thanks, it works but still dunno why the metadata is missing and why it's required to fix/create it?

Contributors